Bug 251919 - xen installation fails : libvirt dependency bug
xen installation fails : libvirt dependency bug
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.1
i686 Linux
low Severity low
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-13 10:19 EDT by Rachid Zarouali
Modified: 2010-09-25 17:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-14 00:42:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rachid Zarouali 2007-08-13 10:19:43 EDT
Description of problem:
dependency bug between libvirt and libvirt-python:
" Error: Missing Dependency: libvirt = 0.2.3-0 is needed by package libvirt-python"

Version-Release number of selected component (if applicable):
libvirt-python.i386 0:0.2.3-4.el5

How reproducible:
fresh installation of a rhel5 i386 updated to rhel5.1 beta 
and xen installation

Steps to Reproduce:
1. install a fresh rhel5 i386 
2. update 
3. activate on rhn website 
 - Red Hat Enterprise Linux (v. 5 for 32-bit x86) Beta
 - RHEL Virtualization (v. 5 for 32-bit x86) Beta  
 - RHEL Supplementary (v. 5 for 32-bit x86) Beta  
4. yum install xen kernel-xen 

Actual results:
--> Processing Dependency: libvirt = 0.2.3-0 for package: libvirt-python
--> Finished Dependency Resolution
Error: Missing Dependency: libvirt = 0.2.3-0 is needed by package libvirt-python

Expected results:
successfull installation of xen and kernel-xen with all packages needed
including libvirt, libvirt-python, virt-manager ....

Additional info:
Comment 1 Daniel Berrange 2007-08-13 17:38:01 EDT
This is either a yum or RHN bug. 

The RPM dependancy is just fine:

%package python
Requires: libvirt = %{version}

This has not changed in ages & works just fine with regular Fedora YUM.

The RHN beta channels are populated with the matching pair of

libvirt-0.2.3-4.el5.i386.rpm
libvirt-python-0.2.3-4.el5.i386.rpm

https://rhn.redhat.com/network/software/packages/dependencies.pxt?pid=411038
https://rhn.redhat.com/network/software/packages/dependencies.pxt?pid=411040

Comment 2 Daniel Berrange 2007-08-13 17:49:01 EDT
Based on the error message

" Error: Missing Dependency: libvirt = 0.2.3-0 is needed by package libvirt-python"

I'd say that yum was mistakenly adding/inventing the  '-0'  release part of the
dependancy when in fact the dep is merely  'libvirt = %{version}'. Since the
base package has a release of -4.el5 it then fails to satisfy this -0 requirement.
Comment 3 James Antill 2007-08-27 17:58:52 EDT
 What version of yum, there we had a planned errata but it had a bunch of
dependancy problems and so is pulled. Can you try with the GA version of yum?
Comment 4 Rachid Zarouali 2007-08-28 05:48:01 EDT
here the version of yum used right know on the RHEL 5.1beta box:
yum-3.2.1-4.el5
by the way , 
what do you mean by GA version ?
Comment 5 James Antill 2007-10-14 00:42:10 EDT
 The iniital release of yum, for RHEL-5.0 the first so called Generally
Available (GA) release was version yum-3.0.1-5.el5.
 The one you have was one of the proposed updates for RHEL-5.1, and was included
in some of the Beta cycle ... but was withdrawn, and will not be part of RHEL-5.1.

 You need to downgrade to the GA version of yum.

Note You need to log in before you can comment on or make changes to this bug.