Bug 251953 - [compiz-0.5.2-3] renders solid white drop shadows for 'radeon' driver
Summary: [compiz-0.5.2-3] renders solid white drop shadows for 'radeon' driver
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-13 17:04 UTC by Joachim Frieben
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 21:11:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample screenshot showing white "drop shadows" (4.48 KB, image/png)
2007-08-13 17:04 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2007-08-13 17:04:42 UTC
Description of problem:
After enabling "Desktop Effects", windows are rendered with drop shadows
as expected. However, this is not the case for the panel and its menus.
Drop shadows are simply replaced by white areas of same dimensions.

Version-Release number of selected component (if applicable):
compiz-0.5.2-3.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Log into "GNOME" session.
2. Enable "Desktop Effects".
  
Actual results:
Top and bottom panels exhibit adjacent white bars. The same applies
to menus when opened - both those of panels or other ["GTK" based]
applications.

Expected results:
Both panels are accompanied by drop shadows, and so are the menus
when opened.

Additional info:
There existed some decorator problems for the latest "compiz" versions
but before, everything seemed to work correctly although extremely
sluggishly compared to previous releases.
The graphics card is an "R100" based "ATI Radeon All in Wonder".
Unfortunately, I have not other system at hand in order to test "compiz"
for a driver other than the "radeon" one.

Comment 1 Joachim Frieben 2007-08-13 17:04:42 UTC
Created attachment 161188 [details]
Sample screenshot showing white "drop shadows"

Comment 2 Kristian Høgsberg 2007-08-15 14:37:06 UTC
I see that on my 965 too, investigating.

Comment 3 Kristian Høgsberg 2007-08-15 21:11:57 UTC
Turns out to be a problem with texture target for power-of-two textures.  Should
be fixed by upgrading to compiz 0.5.2-5.0ec3ec (which will pull in new Xorg and
mesa).


Note You need to log in before you can comment on or make changes to this bug.