Bug 251953 - [compiz-0.5.2-3] renders solid white drop shadows for 'radeon' driver
[compiz-0.5.2-3] renders solid white drop shadows for 'radeon' driver
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-08-13 13:04 EDT by Joachim Frieben
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-15 17:11:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Sample screenshot showing white "drop shadows" (4.48 KB, image/png)
2007-08-13 13:04 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2007-08-13 13:04:42 EDT
Description of problem:
After enabling "Desktop Effects", windows are rendered with drop shadows
as expected. However, this is not the case for the panel and its menus.
Drop shadows are simply replaced by white areas of same dimensions.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Log into "GNOME" session.
2. Enable "Desktop Effects".
Actual results:
Top and bottom panels exhibit adjacent white bars. The same applies
to menus when opened - both those of panels or other ["GTK" based]

Expected results:
Both panels are accompanied by drop shadows, and so are the menus
when opened.

Additional info:
There existed some decorator problems for the latest "compiz" versions
but before, everything seemed to work correctly although extremely
sluggishly compared to previous releases.
The graphics card is an "R100" based "ATI Radeon All in Wonder".
Unfortunately, I have not other system at hand in order to test "compiz"
for a driver other than the "radeon" one.
Comment 1 Joachim Frieben 2007-08-13 13:04:42 EDT
Created attachment 161188 [details]
Sample screenshot showing white "drop shadows"
Comment 2 Kristian Høgsberg 2007-08-15 10:37:06 EDT
I see that on my 965 too, investigating.
Comment 3 Kristian Høgsberg 2007-08-15 17:11:57 EDT
Turns out to be a problem with texture target for power-of-two textures.  Should
be fixed by upgrading to compiz 0.5.2-5.0ec3ec (which will pull in new Xorg and

Note You need to log in before you can comment on or make changes to this bug.