Bug 251965 - "iscsiadm: encountered connection failure - error 4" during boot up.
"iscsiadm: encountered connection failure - error 4" during boot up.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
5.3
All Linux
low Severity low
: ---
: 5.5
Assigned To: Mike Christie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-13 13:55 EDT by Fong Banh
Modified: 2010-10-22 13:29 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-02 14:40:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fong Banh 2007-08-13 13:55:39 EDT
Description of problem:
iscsiadm is reporting an error code 4 (encountered connection failure) during
boot. We think it is because of the order/speed of which the NIC being brought
online.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Establish a discovery session and log into the target.
2. Get a list of volumes from the target.
3. Reboot the host.
  
Actual results:
You see the error occur during boot. The NIC script run before the iSCSI
initiator script does, however you still get a connection error.

Expected results:
The initiator is supposed to successfully log in to the target during boot up.

Additional info:
You can create a normal session with the target after the host has completely
booted up. The connection problem only occurs while the host is coming online.
Comment 1 Mike Christie 2007-09-05 12:57:01 EDT
Could you try the 5.1 beta?

Also what NIC is this with? Did I ask this before?

There are is a bug where the network layer or a NIC is reporting that everything
is ready to go, but it is not, so when we get to the iscsi startup we cannot log
in because the network is not up.

In 5.1 I added a wait and retry to the iscsi startup to work around network
issues and transient errors.
Comment 2 khtan 2007-09-06 12:13:53 EDT
We've retested with the latest 5.1 beta and on a reboot auto login still fails.
Comment 3 Mike Christie 2007-09-06 16:35:02 EDT
Could you run iscsid with -d 8 and send the log output?
Comment 4 Mike Christie 2007-09-06 17:10:11 EDT
ignore that last request. It is going to be a pain for you to do that.
Comment 5 RHEL Product and Program Management 2007-12-06 16:44:38 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 RHEL Product and Program Management 2008-03-11 15:42:31 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 7 Mike Christie 2008-03-11 16:15:55 EDT
LSI, are you using DHCP or static ips on the initiator side?
Comment 8 Fong Banh 2008-03-13 11:21:28 EDT
Static IPv4 addresses.
Comment 9 Mike Christie 2008-03-13 11:30:21 EDT
Ok, try increasing node.session.initial_login_retry_max
to 15 or 30.
Comment 10 Fong Banh 2008-03-14 09:40:19 EDT
Neither of those values worked. I see the connection failures, however all of
the sessions appear to come up correctly. With RHEL5 U1, this issue seems to be
just a cosmetic issue now.
Comment 11 Mike Christie 2008-03-14 13:06:12 EDT
(In reply to comment #10)
> Neither of those values worked. I see the connection failures, however all of
> the sessions appear to come up correctly.

You lost me :) Do you see connection failures from iscsid, but iscsiadm ends up
connecting so you see iscsiadm return a message that the session was established
eventually?
Comment 12 Fong Banh 2008-04-17 16:10:44 EDT
Sorry for the long delay in my reply. I finally got around to re-examining this
issue and found it to be completely fixed in RHEL5 U1. Comment #10 was in
regards to the other iSCSI host ports that are not plugged in, but still have an
IP address (array defaults to a 192.168.x.x address if not configured). Our
arrays will send all target information in the text response of a "send targets"
command, and this was what I was seeing time out. I did not have to adjust the
node.session.initial_login_retry_max value.
Comment 13 Kostas Georgiou 2008-05-11 12:56:01 EDT
I noticed a similar problem with root iscsi on a xen domU, if the bridge's
forward delay setting is higher than the timeout that iscsistart uses. I guess
this "bug" belongs to anaconda?
Comment 14 RHEL Product and Program Management 2008-06-02 16:33:52 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 15 Mike Christie 2008-06-27 22:11:49 EDT
(In reply to comment #13)
> I noticed a similar problem with root iscsi on a xen domU, if the bridge's
> forward delay setting is higher than the timeout that iscsistart uses. I guess
> this "bug" belongs to anaconda?

I do not think anaconda is going to do anything for this. You have to set the
timeout higher yourself. I actually increased it to over two minutes (we allow
something like 120 retries) for 5.2.

For RHEL 5.3 I can make it so we can configure this if you are still having
troubles.
Comment 17 RHEL Product and Program Management 2008-10-27 14:22:26 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 18 Mike Christie 2009-06-12 22:29:46 EDT
Move to 5.5. The default is pretty high now, so we have not got any reports of people still hitting this.

Note You need to log in before you can comment on or make changes to this bug.