Bug 25199 - Install fails, no partition created
Install fails, no partition created
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-29 12:59 EST by Mark Jaffe
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-29 19:16:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Jaffe 2001-01-29 12:59:00 EST
Current system (40 Gb HD) contains two MS partitions (FAT for Win2K and 
NTFS for development on Windoze) and remainder (approx 29 Gb) which had 
contained a Mandrake 7.0 installation. Attempting to install RedHat 7.0 
over Mandrake failed, using existing partition map. I then re-partitioned 
the remainder of the disk as / and experienced the same error. What I 
experience is stepping through the installer up to the point of disk 
formatting, then a VERY LONG wait for formatting of / partition, then an 
error dialog which I save the contents to a floppy disk which can then NOT 
BE READ! I did not bother to write it down, as I performed the steps as 
suggested to save it to a floppy. But the floppy can not mount. 

I'll come back and append stuff after I try to install again...
Comment 1 Mark Jaffe 2001-01-29 13:07:14 EST
Ha, ha, ha!! Since I could not read the floppy on my Win2K, I took it over to 
my PowerBook, which had NO PROBLEM mounting it as a DOS-format floppy. Here's 
the contents of the file anacdump.txt:

Traceback (innermost last):
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 
20, in run
    rc = self.todo.doInstall ()
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, 
self.instPath, self.hdList.selected()):
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + 
fstab.filesystemSpace(mntPoint)[0][0] + \
  File 
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, 
isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File 
"/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return 
_isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or 
directory')

Local variables in innermost frame:
fsystem: 
/mnt/sysimage//mnt/windows_c

ToDo 
object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


Comment 2 Michael Fulbright 2001-01-29 19:16:08 EST
Fixed by an errata.

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.