Bug 251999 - Thunderbird throws glibc double free or corruption error
Thunderbird throws glibc double free or corruption error
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
: Desktop
Depends On:
  Show dependency treegraph
Reported: 2007-08-13 14:44 EDT by Meethune Bhowmick
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-11 14:59:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Backtrace of crash (7.42 KB, text/plain)
2007-08-13 14:44 EDT, Meethune Bhowmick
no flags Details
After update to thunderbird- (8.92 KB, text/plain)
2007-08-14 11:59 EDT, Meethune Bhowmick
no flags Details
Full backtrace from gdb (6.01 KB, application/x-gzip)
2007-08-21 14:18 EDT, Meethune Bhowmick
no flags Details
Patch to fix crash (1.06 KB, patch)
2007-08-21 16:32 EDT, Meethune Bhowmick
no flags Details | Diff

  None (edit)
Description Meethune Bhowmick 2007-08-13 14:44:11 EDT
Description of problem:
When setting up a new profile in thunderbird, it crashes with a glibc double
free or corruption error. In my particular case, I was setting up my imap
account. When I went to account settings to change from regular to ssl, the
error gets thrown as soon as the account settings window pops up.
I also noted that if I restart thunderbird, with the profile created, and try to
access the account settings menu, it straight seg faults.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start with fresh profile
2. Setup IMAP account
3. Go to accounts settings
Actual results:
Backtrace attached
Process actually hangs and I have to ctrl+c it to quit.

Expected results:
No crash

Additional info:
Comment 1 Meethune Bhowmick 2007-08-13 14:44:11 EDT
Created attachment 161203 [details]
Backtrace of crash
Comment 2 Meethune Bhowmick 2007-08-14 11:59:05 EDT
Created attachment 161279 [details]
After update to thunderbird-

I ran a system update today. There was a new thunderbird package. I tried the
procedure I described initially again. This time it crashed with a free()
invalid next. Attached is the backtrace.
Comment 3 Meethune Bhowmick 2007-08-21 14:18:40 EDT
Created attachment 161993 [details]
Full backtrace from gdb

So I went ahead and ran a full backtrace using gdb. In particular look at
Thread 2.
Comment 4 Meethune Bhowmick 2007-08-21 14:20:24 EDT
Actually, I figured it out. It is my gtk theme. It seems to be directly related
to this bug (https://bugzilla.mozilla.org/show_bug.cgi?id=389801). When I
changed to the standard theme that comes w/ F8, thunderbird works fine. I'm
applying the patch in the mozilla bug and recompiling to see if that fixes the
issue. If that is the case then this patch needs to be applied to both firefox
and thunderbird.
Comment 5 Meethune Bhowmick 2007-08-21 16:32:42 EDT
Created attachment 162005 [details]
Patch to fix crash

This patch is taken from (https://bugzilla.mozilla.org/show_bug.cgi?id=389801).
I applied it to thunderbird- and rebuilt the rpm. This fixes the
issue for both thunderbird and firefox. With this patch, I can run firefox and
thunderbird with my brushed metal gtk+ theme without it crashing.
Comment 6 Christopher Aillon 2007-09-11 14:59:21 EDT
Fixed in thunderbird- and firefox-

Note You need to log in before you can comment on or make changes to this bug.