Bug 252112 - yumdowloader --resolve only downloads non-installed dependencies
yumdowloader --resolve only downloads non-installed dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-13 18:20 EDT by Andrew Rechenberg
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-13 18:22:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Rechenberg 2007-08-13 18:20:43 EDT
Description of problem:
yumdownloader --resolve seems to only download the specified package if the
dependencies for said package are already installed.  I'm not sure if this is
intended behavior, but IMO all dependent packages should be downloaded.

Version-Release number of selected component (if applicable):
yum-utils-1.1.6-1.fc7

How reproducible:
Everytime

Steps to Reproduce:
1. Install yum-utils
2. yumdownloader --resolve bash
3. Only bash is downloaded instead of bash, glibc, mktemp, ncurses etc.
  
Actual results:
Only named package is downloaded

Expected results:
Named package as well as all dependencies should be downloaded IMO.

Additional info:
If this behavior is intended, is there a quick and dirty description of what
could be done in the code to allow all dependencies to be downloaded?  I am
trying to build a koji server and want to download all dependencies for a
buildgroup and using yumdownloader would make it much easier.
Comment 1 Seth Vidal 2007-08-13 18:22:50 EDT
yumdownloader is made for downloading the dependencies for the system it is
running on. If you want a tool to download all the deps in the remote repo look
at repotrack - also in yum-utils.


Note You need to log in before you can comment on or make changes to this bug.