Bug 252126 - wrong passwd blocks authentication
wrong passwd blocks authentication
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-13 21:26 EDT by Jens Petersen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 20:05:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2007-08-13 21:26:34 EDT
Description of problem:
If one puts in the wrong password then it is not possible
to get authenticated with the correct password until pressing Cancel.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.19.6-4.fc8

How reproducible:
every time

Steps to Reproduce:
1. log desktop
2. type in wrong password
3. type in right password
  
Actual results:
3. password rejected

Expected results:
3. password accepted

Additional info:
Hope this is not considered a feature?
Comment 1 Ray Strode [halfline] 2007-08-14 09:45:27 EDT
Not a feature.  My guess is somewhere in the PAM stack it's blocking.

Can you attach your /etc/pam.d/system-auth file?
Comment 2 Ray Strode [halfline] 2007-08-14 11:41:07 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to CANTFIX, however if you still
experience this problem after updating to our latest Fedora
Core release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thank you in advance.

(this message is mass message)
Comment 3 Jens Petersen 2007-08-15 06:48:24 EDT
Heh, this bug was filed yesterday... reopened.
Comment 4 Ray Strode [halfline] 2007-08-15 09:50:53 EDT
grrr, i'm not sure what happened there.  The bugzilla boolean chart thing has
beaten me...
Comment 5 Jens Petersen 2007-08-15 20:05:29 EDT
No worries - anyway this seems to be fixed now in current rawhide.

Note You need to log in before you can comment on or make changes to this bug.