Bug 252146 - glibc-2.6.90-9 looks ignoring /etc/ld.so.conf.d/*.conf
Summary: glibc-2.6.90-9 looks ignoring /etc/ld.so.conf.d/*.conf
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
low
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-14 10:01 UTC by kanagawa jigorou
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 2.6.90-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 00:30:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ldc.log (374.24 KB, application/octet-stream)
2007-08-14 15:42 UTC, kanagawa jigorou
no flags Details
ldc2.log (24.11 KB, application/octet-stream)
2007-08-14 15:43 UTC, kanagawa jigorou
no flags Details
ldc3 (46.99 KB, application/octet-stream)
2007-08-14 18:25 UTC, kanagawa jigorou
no flags Details

Description kanagawa jigorou 2007-08-14 10:01:20 UTC
Description of problem:


Version-Release number of selected component (if applicable):
glibc-2.6.90-9

How reproducible:
upgrade glibc to glibc-2.6.90-9

Steps to Reproduce:
1.only upgrading glibc to glibc-2.6.90-9

Actual results:
can't run programs using libraries in /etc/ld.so.conf.d/*.conf.
ex. Qt/KDE, octave, etc...
console said that
[jigorou ~]$ konqueror
konqueror: error while loading shared libraries: libqt-mt.so.3: cannot open
shared object file: No such file or directory
[jigorou ~]$ octave
octave: error while loading shared libraries: liblapack.so.3: cannot open shared
object file: No such file or directory

Expected results:
use /etc/ld.so.conf.d/*.conf and load libraries correctly.

Comment 1 Jakub Jelinek 2007-08-14 14:22:54 UTC
Can't reproduce.
Can you:
cat /etc/ld.so.conf
strace -o /tmp/ldc.log /sbin/ldconfig -v | tee /tmp/ldc2.log
cat /tmp/ldc.log
cat /tmp/ldc2.log
and check if you don't get any SELinux audit messages?

Comment 2 kanagawa jigorou 2007-08-14 15:41:03 UTC
Ok.
with glibc-2.6.90-9,
[jigorou ~]$ cat /etc/ld.so.conf
include ld.so.conf.d/*.conf
/usr/lib/wine
[jigorou ~]$ strace -o /tmp/ldc.log /sbin/ldconfig -v | tee /tmp/ldc2.log
...

Comment 3 kanagawa jigorou 2007-08-14 15:42:12 UTC
Created attachment 161275 [details]
ldc.log

Comment 4 kanagawa jigorou 2007-08-14 15:43:02 UTC
Created attachment 161276 [details]
ldc2.log

Comment 5 kanagawa jigorou 2007-08-14 15:46:15 UTC
> and check if you don't get any SELinux audit messages?
No.
Because I disabled both SELinux and auditd.

Comment 6 Jakub Jelinek 2007-08-14 18:14:25 UTC
Both /usr/lib/octave-2.9.13/ and /usr/lib/qt-3.3/lib/ directories were clearly
scanned though and libraries in it read.
Can you /sbin/ldconfig -p | tee /tmp/ldc3.log
?


Comment 7 kanagawa jigorou 2007-08-14 18:25:00 UTC
Created attachment 161291 [details]
ldc3

Ok.
and 'grep qt' output here

[root@localhost tmp]# cat ldc3.log |grep qt
	libqui.so.1 (libc6) => /usr/lib/qt-3.3/lib/libqui.so.1
	libqui.so (libc6) => /usr/lib/qt-3.3/lib/libqui.so
	libqtmcop.so.1 (libc6) => /usr/lib/libqtmcop.so.1
	libqtmcop.so (libc6) => /usr/lib/libqtmcop.so
	libqt-mt.so.3 (libc6) => /usr/lib/qt-3.3/lib/libqt-mt.so.3
	libqt-mt.so.3 (libc6) => /usr/lib/libqt-mt.so.3
	libqt-mt.so (libc6) => /usr/lib/qt-3.3/lib/libqt-mt.so
	libkdevqtimporter.so (libc6) => /usr/lib/libkdevqtimporter.so
	libdbus-qt-1.so.1 (libc6) => /usr/lib/libdbus-qt-1.so.1


hmm....
>	 libqt-mt.so.3 (libc6) => /usr/lib/libqt-mt.so.3
cause this problem?(...only for me?)

Comment 8 Jakub Jelinek 2007-08-14 18:34:22 UTC
The problem is actually not in ldconfig at all, but in a recent ld.so change:
http://sourceware.org/cgi-bin/cvsweb.cgi/libc/elf/dl-misc.c.diff?cvsroot=glibc&r1=1.35&r2=1.36
Apparently O_NOATIME is allowed only for the file owner or fsuid user.

Comment 9 kanagawa jigorou 2007-08-14 19:09:57 UTC
Oh!

And now, I discovered that
this problem doesn't happen if I'm root.
(Qt,octave run without problem.)

Thanks!


Note You need to log in before you can comment on or make changes to this bug.