Bug 25215 - XFree86 should not depend on glide3
Summary: XFree86 should not depend on glide3
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-29 19:50 UTC by Daryll
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-15 03:26:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daryll 2001-01-29 19:50:57 UTC
There is a dependency for the XFree86 package to have Glide3 installed.
This shouldn't
be true. To get hardware acceleration on a 3dfx card you need glide, but no
one else does and the system gracefully falls back to software rendering if
glide3 isn't found.

Comment 1 Mike A. Harris 2001-01-29 20:15:30 UTC
The dependancy on Glide is a known issue which will be addressed in a
future release of Red Hat Linux.  The problem fix involves splitting
all drivers into separate packages which is not going to happen right
away.

Comment 2 Mike A. Harris 2001-05-15 03:26:36 UTC
Glide 3 is not a library intended for other programs to use.  It is ONLY
functional with DRI which is a core part of XFree86, and the 3dfx driver is
in effect a small wrapper + Glide3.  As such, Glide3 has been integrated
into the XFree86 packaging because it is a core part of DRI for 3dfx and is
used by nothing else.  Splitting up the XFree86 package into separate
packages for each driver has zero benefit and instead would create a lot
of problems for no real good reason.

Comment 3 Mike A. Harris 2001-05-15 03:31:47 UTC
Duh...  I just realized AFTER posting - who reported it in the first place.
Guess I didn't need to say all that..  ;o)  It was your own help on this
that made me decide to keep Glide in the XFree86 packaging.  ;o)

I guess I should read more closely before telling someone back the advice
they've given to me eh?  LOL!  ;o)

Guess, this should be considered "resolved rawhide" since the dependancy is
now gone (via assimilation).  ;o)

Take care.


Note You need to log in before you can comment on or make changes to this bug.