Bug 252185 - Mailman init script prevents proper SELinux domain transitions
Summary: Mailman init script prevents proper SELinux domain transitions
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mailman   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Tomas Smetana
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 350511
Blocks: 242672
TreeView+ depends on / blocked
 
Reported: 2007-08-14 16:16 UTC by Aleksander Adamowski
Modified: 2008-05-21 16:04 UTC (History)
0 users

Fixed In Version: RHBA-2008-0416
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 16:04:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch to get rid of direct interpreter invocation in mailman init script (1001 bytes, patch)
2007-08-14 16:16 UTC, Aleksander Adamowski
no flags Details | Diff
AVC messages (4.02 KB, text/plain)
2007-10-23 07:59 UTC, Tomas Smetana
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0416 normal SHIPPED_LIVE mailman bug fix update 2008-05-19 22:34:40 UTC

Description Aleksander Adamowski 2007-08-14 16:16:41 UTC
Description of problem:

The init script that launches mailman qrunners uses the form "interpreter
script" instead of "script" to launch the mailmanctl script. Because of this
proper SELinux domain transitions cannot occur and the Mailman qrunner ends up
in initrc_t domain.

Version-Release number of selected component (if applicable):
mailman-2.1.9-2

How reproducible:
Always

Steps to Reproduce:
1. Start mailman with SELinux in permissive mode.
2. Execute "ps xuwa -Z | grep qrunner"
  
Actual results:
The processes run in initrc_t domain.

Expected results:
The processes should run in mailman_mail_t domain.

Additional info:
A patch against the init script is attached.

Comment 1 Aleksander Adamowski 2007-08-14 16:16:41 UTC
Created attachment 161280 [details]
A patch to get rid of direct interpreter invocation in mailman init script

Comment 2 Tomas Smetana 2007-10-23 07:58:22 UTC
I got some AVC messages after applying the patch.  This means that we might need
to update also the policy and need to test this for some time.  Maybe we should
start with this in Fedora first.

Comment 3 Tomas Smetana 2007-10-23 07:59:44 UTC
Created attachment 234841 [details]
AVC messages

Comment 5 Tomas Smetana 2007-10-24 14:31:19 UTC
I've filled the bug #350511 -- the selinux-policy might need to be changed as well.

Comment 13 errata-xmlrpc 2008-05-21 16:04:12 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0416.html



Note You need to log in before you can comment on or make changes to this bug.