Bug 252208 - Yum refuses to install package compat-wxGTK
Yum refuses to install package compat-wxGTK
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: compat-wxGTK (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-14 14:54 EDT by Mikko Huhtala
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 16:00:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikko Huhtala 2007-08-14 14:54:01 EDT
Description of problem:

Yum refuses to install package compat-wxGTK. 

'yum -y install compat-wxGTK' will actually install wxGTK. If wxGTK is already
installed, the yum command says that wxGTK is already installed and the latest
version (even though what was requested was compat-wxGTK).

compat-wxGTK26 is not installed.

Is compat-wxGTK being deprecated and if so, is this really the way to do it?

Version-Release number of selected component (if applicable):

wxGTK-2.8.4-3.fc7
compat-wxGTK-2.4.2-21.fc6
compat-wxGTK26-2.6.3-2
yum-3.2.1-1.fc7

How reproducible:

Always

Steps to Reproduce:
1. Install and update F7
2. Make sure compat-wxGTK is not installed
3. Do yum -y install compat-wxGTK
  
Actual results:

compat-wxGTK does not get installed.

Expected results:

compat-wxGTK should get installed.
Comment 1 Tom "spot" Callaway 2007-08-14 16:00:55 EDT
Yes, compat-wxGTK is being deprecated. Since we can't take it out of the spins,
the best we can do is to have wxGTK provide/obsolete it.

Nothing should be using the ancient 2.4 code at this point, nothing in Fedora
is, and it was conflicting with other wxGTK code and preventing it from running.

Note You need to log in before you can comment on or make changes to this bug.