Bug 252243 - RHEL5.1: Updates to cxgb3 driver
Summary: RHEL5.1: Updates to cxgb3 driver
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.1
Hardware: All
OS: Linux
urgent
high
Target Milestone: ---
: ---
Assignee: Andy Gospodarek
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords: FutureFeature, OtherQA
Depends On: 222453
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-14 21:05 UTC by Andy Gospodarek
Modified: 2014-06-29 22:59 UTC (History)
10 users (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 19:59:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Comment 1 Andy Gospodarek 2007-08-14 21:10:19 UTC
Divy,

What do you think about the following patch -- should we try and get this added
to 5.1?

http://people.redhat.com/agospoda/rhel5/gtest/cxgb3-fixes.patch

Comment 2 Divy Le Ray 2007-08-14 21:22:56 UTC
Andy, 

It looks good. 

I understood from comment #39 in 222543 that this patch was included in your 
latest images, which we're currently testing. Am I right ?

Divy

Comment 3 Andy Gospodarek 2007-08-14 21:31:36 UTC
Divy,

You are correct.  The sooner you can provide feedback the better because I'd
like to get these updates included.

Do you see this patch as an absolute requirement for you (i.e. do they have
fixes that must be present for the cards to work well)?  I know the checksum
offload didn't with the first patch, but if there is anything else you remember,
let us know.

Thanks,

-andy


Comment 5 Divy Le Ray 2007-08-14 22:03:07 UTC
IMHO, this patch should be included. The driver would use correct profiles for 
both sysfs and interrupt handler routines. We're currently testing a kernel 
image that includes thee bits. 

I'll confirm the current state of testing after touching base with QA. 


Comment 6 Jay Turner 2007-08-15 13:14:23 UTC
Can we depend on Chelsio for performing full regression testing on the updated
driver?

Comment 7 Andy Gospodarek 2007-08-15 13:27:04 UTC
Jay, we can.  They are currently regression testing my test kernels which
contain this patch.

Comment 14 Don Zickus 2007-09-21 20:07:52 UTC
in 2.6.18-49.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 17 errata-xmlrpc 2007-11-07 19:59:19 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.