Bug 252265 - updatedb dies with assertion violation
updatedb dies with assertion violation
Status: CLOSED DUPLICATE of bug 242715
Product: Fedora
Classification: Fedora
Component: mlocate (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-08-14 20:07 EDT by D. Wagner
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-14 20:51:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
gdb backtrace (2.15 KB, application/octet-stream)
2007-08-14 20:07 EDT, D. Wagner
no flags Details

  None (edit)
Description D. Wagner 2007-08-14 20:07:29 EDT
Description of problem:
updatedb dies with an assertion failure

Version-Release number of selected component (if applicable):

How reproducible:
Run updatedb

Steps to Reproduce:
1. Run updatedb as root
2. Watch for the assertion failure
Actual results:
updatedb: src/updatedb.c:721: scan_cwd: Assertion `name_size > 1' failed.

Expected results:
Successful completion

Additional info:
See attached backtrace generated with gdb.
updatedb crashed on a clean Fedora 7 install on my Thinkpad X61 laptop.

P.S. I'm filing this bug from a different machine than the one where the bug
manifests itself.

P.P.S. The "Guided mode" entrance in this Bugzilla is unusable from Firefox. 
When I get to the page with the list of components (rpm packages), it is
unusably slow -- trying to scroll up/down in the list is painfully
non-responsive.  Some problem with the Javascript, maybe?
Comment 1 D. Wagner 2007-08-14 20:07:29 EDT
Created attachment 161317 [details]
gdb backtrace
Comment 2 Miloslav Trmač 2007-08-14 20:51:44 EDT
Thanks for your report.  This bug is already tracked as #242715.

*** This bug has been marked as a duplicate of 242715 ***

Note You need to log in before you can comment on or make changes to this bug.