This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 252288 - AMD/ATI SB600/700/800 use same SMBus controller devID
AMD/ATI SB600/700/800 use same SMBus controller devID
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On: 244615
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-14 23:59 EDT by Shane Huang
Modified: 2007-11-30 17:12 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 18:26:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane Huang 2007-08-14 23:59:10 EDT
+++ This bug was initially created as a clone of Bug #252286 +++

Description of problem:
We find that SB700 and SB800 use the same SMBus device ID as SB600, which is
0x4385, instead of the already submitted 0x4395.
We submitted an error SB700 SMBus patch in the bugzilla# 244615
Please apply the attached new SMBus patch, which can remove the wrong applied
SB700 SMBus patch submitted before.

Besides removing the SB700 wrong patch, the attached patch add SB800 support to
kernel, by renaming the PCI_DEVICE_ID_ATI_IXP600_SMBUS into
PCI_DEVICE_ID_ATI_SBX00_SMBUS.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Always

Steps to Reproduce:
N/A
  
Actual results:
N/A

Expected results:
N/A

Additional info:
Would you please help to apply this new patch ASAP before the release of
Fedora 8? Because the error device ID 0x4395 will be used in SB800 SATA
controller.

I have sent this new patch to kernel.org, I will send you the upstream commit
after they apply it.

The patch is generated on the base of linux-2.6.23-rc3, so maybe you need do
some small backport to it when you apply it.

-- Additional comment from shane.huang@amd.com on 2007-08-14 23:46 EST --
Created an attachment (id=161327)
SB600/SB700/SB800 use same SMBus controll device ID
Comment 1 Chuck Ebbert 2007-08-22 18:26:39 EDT
This was never in 2.6.22, so not a problem in Fedora 7.
Comment 2 Shane Huang 2007-08-31 06:00:50 EDT
upstream commit:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-
2.6.git;a=commit;h=60693e5a9a2063b87d4dbe8029816c814b3fa84e

Note You need to log in before you can comment on or make changes to this bug.