Bug 252303 - mkinitrd does not allow exclusion of usb modules though option --without-usb is evaluated
mkinitrd does not allow exclusion of usb modules though option --without-usb ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Brian Lane
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-15 03:54 EDT by Christoph Szeppek
Modified: 2014-04-14 14:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-14 14:36:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for mkinitrd-5.1.19.6-1 (857 bytes, patch)
2007-08-15 03:54 EDT, Christoph Szeppek
no flags Details | Diff

  None (edit)
Description Christoph Szeppek 2007-08-15 03:54:20 EDT
Description of problem:
mkinitrd does not allow the exclusion of usb modules. There is a commandline 
option --without-usb that is evaluated but not documented and does not work.

Version-Release number of selected component (if applicable):
mkinitrd-5.1.19.6-1

How reproducible:
always

Steps to Reproduce:
1. build an initial ramdisk with --without-usb option
2. extract the initrd
3. check if the init script loads the ?hci-hcd modules.

Actual results:
usb modules will be loaded

Expected results:
no usb module loaded.

Additional info:
Comment 1 Christoph Szeppek 2007-08-15 03:54:21 EDT
Created attachment 161335 [details]
Patch for mkinitrd-5.1.19.6-1
Comment 2 RHEL Product and Program Management 2013-05-01 02:43:46 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2014-01-29 05:40:48 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Brian Lane 2014-04-14 14:33:54 EDT
This has been fixed for a very long time.

That block of code currently looks like:

if [ "$withusb" -eq 1 ]; then
Comment 5 RHEL Product and Program Management 2014-04-14 14:36:21 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.