This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 252319 - Xorg should consider locale settings when autodetecting keyboard layout without xorg.conf
Xorg should consider locale settings when autodetecting keyboard layout witho...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-15 07:46 EDT by Peter Robinson
Modified: 2008-10-03 00:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.5.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 00:35:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.log file with no xorg.conf file (68.81 KB, text/plain)
2007-08-17 06:40 EDT, Peter Robinson
no flags Details

  None (edit)
Description Peter Robinson 2007-08-15 07:46:33 EDT
Not sure if this is xorg/gnome or some other component so filing under the
xorg-x11-server to start with and its not specific to the xorg-x11-drv-i810
driver as I wouldn't think this is display driver specific.

When I remove my xorg.conf file so the display is auto detected and configured
(using the new intel driver) the X server defaults to the US layout without
properly setting the keyboard.

GNOME already knows what this setting is because if I go into the
System->Administration->Keyboard utility the United Kingdom keyboard is already
selected. All I have to do is click on it and click OK and the UK keyboard works
fine.

Without a config file X should probably be able to get the keyboard config from
the desktop env so they keyboard can be properly set as this could cause login
issues with passwords prior to login etc.
Comment 1 Matěj Cepl 2007-08-15 12:53:42 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Peter Robinson 2007-08-17 06:40:35 EDT
Created attachment 161725 [details]
xorg.log file with no xorg.conf file

Attached is the log file. As the problem occurs when there is no xorg.conf file
I can't attach one as it doesn't exist.
Comment 3 Peter Robinson 2008-03-26 06:28:05 EDT
Updating this to rawhide as its still an issue
Comment 4 Bug Zapper 2008-05-13 23:07:32 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Peter Hutterer 2008-08-29 03:29:11 EDT
FYI, xorg-x11-server-1.4.99.906-4 (rawhide) and later read the configuration from /etc/sysconfig/keyboard and apply the layout automatically.
Comment 6 Peter Hutterer 2008-10-03 00:35:59 EDT
(In reply to comment #0)
> GNOME already knows what this setting is because if I go into the
> System->Administration->Keyboard utility the United Kingdom keyboard is already
> selected. All I have to do is click on it and click OK and the UK keyboard works
> fine.

The keyboard switcher in gnome works again with 1.5.0. This is persistent and should thus solve the issue described by the original reporter.

For F10, the keyboard layout is also read from /etc/sysconfig/keyboard at startup.

Note You need to log in before you can comment on or make changes to this bug.