Bug 252338 - Totem doesn't play ogg video
Totem doesn't play ogg video
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-15 10:11 EDT by Rafał Polak
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-03 14:32:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console output (3.99 KB, text/plain)
2007-08-15 10:12 EDT, Rafał Polak
no flags Details
console log nr 2 (3.97 KB, text/plain)
2007-08-15 10:14 EDT, Rafał Polak
no flags Details
bug buddy crash example (29.12 KB, text/plain)
2007-08-15 13:39 EDT, Rafał Polak
no flags Details
bug buddy crash example 2 (50.11 KB, text/plain)
2007-08-15 13:40 EDT, Rafał Polak
no flags Details

  None (edit)
Description Rafał Polak 2007-08-15 10:11:31 EDT
Description of problem:
Totem can't play ogg video, it hangs at start or doesn't play video at all.

Version-Release number of selected component (if applicable):
totem-2.18.1-3.fc7

How reproducible:
I would say it's 8/10 times.

Steps to Reproduce:
1.open ogg video file
 
Actual results:
Totem doesn't play it and hangs

Expected results:
Totem should play it

Additional info:
Comment 1 Rafał Polak 2007-08-15 10:12:53 EDT
Created attachment 161360 [details]
console output
Comment 2 Rafał Polak 2007-08-15 10:14:06 EDT
Created attachment 161361 [details]
console log nr 2
Comment 3 Bastien Nocera 2007-08-15 11:36:23 EDT
It looks like it's specific to the video. Could you please tell me the exact
versions of GStreamer and plugins used, as well as gathering a backtrace with
debuginfo[1]?

It would also be useful if you could check whether every Theora video is doing
this, and if not, make the video that's causing the problem available.

[1]: http://fedoraproject.org/wiki/StackTraces
Comment 4 Rafał Polak 2007-08-15 13:38:33 EDT
Installed gstreamer packages :

gstreamer.x86_64                         0.10.13-0.1.fc7        installed       
gstreamer-debuginfo.x86_64               0.10.13-0.1.fc7        installed       
gstreamer-plugins-base.x86_64            0.10.12-2.fc7          installed       
gstreamer-plugins-base-debuginfo.x86_64  0.10.12-2.fc7          installed       
gstreamer-plugins-good.x86_64            0.10.5-6.fc7           installed       
gstreamer-plugins-good-debuginfo.x86_64  0.10.5-6.fc7           installed       
gstreamer-tools.x86_64                   0.10.13-0.1.fc7        installed 

Not every video causes this, just some of them. So far I have problems with
FudCon 2007 - Boston videos from http://torrent.fedoraproject.org 

I did sha1sum check but can't find any shasum file to compare these results :

800d290811f99a7bea189dc0f4471990da088760  fudcon-boston-2007-intro.ogg
bfcca30c3a444cddd09a75756666d099b60dea75  fudcon-boston-2007-k12ltsp.ogg
7cf8fe060beb3817b9e5d85f3fed35972885e87a  fudcon-boston-2007-lowering-barriers.ogg
a6b0d8df81414485dcc24cdad1b4db2a744e7cff  fudcon-boston-2007-olpc.ogg
1ddc2f4697facbfcb770ce32073b103d241450d6  fudcon-boston-2007-single-sign-on.ogg
14bc2396402df7a165aa459e534dfc12b43c5017  fudcon-boston-2007-state-of-the-union.ogg
Comment 5 Rafał Polak 2007-08-15 13:39:42 EDT
Created attachment 161382 [details]
bug buddy crash example
Comment 6 Rafał Polak 2007-08-15 13:40:14 EDT
Created attachment 161383 [details]
bug buddy crash example 2
Comment 7 Bastien Nocera 2007-08-20 09:03:47 EDT
Please upgrade your gstreamer-plugins-good and associated to the latest F7
version, as well as libtheora to 1.0alpha8-0.1.svn13393.fc7 (all available in
updates-testing) and let me know whether this fixes the problem.
Comment 8 Rafał Polak 2007-09-03 14:00:30 EDT
I did as you said :

gstreamer.x86_64                         0.10.13-0.1.fc7        installed       
gstreamer-plugins-base.x86_64            0.10.13-1.fc7          installed       
gstreamer-plugins-good.x86_64            0.10.6-1.fc7           installed       
gstreamer-tools.x86_64                   0.10.13-0.1.fc7        installed
libtheora.x86_64                         1.0alpha8-0.1.svn13393 installed

and everything works good now. There was another issue with Totem. After closing
Totem its process didn't die and I wanted to report that but it seems to be also
fixed by updating those packages.
Comment 9 Bastien Nocera 2007-09-03 14:32:45 EDT
Great stuff, closing now.

Note You need to log in before you can comment on or make changes to this bug.