Bug 252341 - yum should not exit on missing update dependencies
Summary: yum should not exit on missing update dependencies
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 6
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-15 14:28 UTC by Thomas Ahle
Modified: 2014-01-21 22:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 18:57:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Ahle 2007-08-15 14:28:48 UTC
Description of problem:
When yum fails a "yum update" because of missing dependencies, it should ask the
user to skip the failing packages and update the rest of them.

Comment 1 Jeremy Katz 2007-09-13 18:57:20 UTC
Skipping one package can end up with a long chain of skipping and is
intentionally not done by default.  Install the skip-broken plugin and use it
with --skip-broken if you want this behavior.


Note You need to log in before you can comment on or make changes to this bug.