Bug 252361 - xm create complains about keymap option in vfb[]
Summary: xm create complains about keymap option in vfb[]
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen   
(Show other bugs)
Version: 5.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Daniel Berrange
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-15 16:51 UTC by Cole Robinson
Modified: 2018-10-19 22:28 UTC (History)
1 user (show)

Fixed In Version: RHEA-2007-0635
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 17:11:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2007:0635 normal SHIPPED_LIVE xen enhancement update 2007-10-30 15:49:02 UTC

Description Cole Robinson 2007-08-15 16:51:18 UTC
Description of problem:

The latest libvirt/virt-manager combo creates xen configuration files with
a parameter xm doesn't recognize. An example of the offending line from an
/etc/xen file is:

  vfb = [ "type=vnc,vncunused=1,keymap=en_us" ]

Trying to 'xm create' the config file errors with:

  Error: configuration option keymap unknown to vfbs

This change came about via the patch to libvirt for bug 250789. In GA we used
the vfb[] format, but (at least by a default virt-manager guest install) the
keymap option was not present. So this could be a libvirt issue, but since xm
list --long shows the 'keymap' option coupled with the rest of the vfb options
in the sexpr, this option should probably be recognized by xm.

libvirt-0.2.3-7.el5
virt-manager-0.4.0-3.el5
xen-3.0.3-35.el5
xen-libs-3.0.3-35.el5
kernel = 2.6.18-37.el5xen

How reproducible:
Always

Steps to Reproduce:
1. Create a new guest in virt-manager
2. Shutdown the guest
3. 'xm create /etc/xen/GUESTNAME' and receive the error

Expected results:
No error, guest starts up.

Comment 5 Daniel Berrange 2007-08-27 22:54:46 UTC
Patch applied in

* Mon Aug 27 2007 Daniel P. Berrange <berrange@redhat.com> - 3.0.3-37.el5
- Fix handling of 'keymap' param in config files (rhbz #252361)


Comment 10 errata-xmlrpc 2007-11-07 17:11:27 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0635.html



Note You need to log in before you can comment on or make changes to this bug.