Bug 252369 - Fc6 to F7 Restart Hangs Both Ways
Fc6 to F7 Restart Hangs Both Ways
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-15 13:21 EDT by Kelly-Rand
Modified: 2008-01-11 16:13 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.23.12-52
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 16:13:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screen shot of boot error message (392.69 KB, image/jpeg)
2007-08-20 19:17 EDT, Kelly-Rand
no flags Details

  None (edit)
Description Kelly-Rand 2007-08-15 13:21:15 EDT
Description of problem:
The behavior below began with the latest kernel versions, the ones that changed
the naming convention.

Fc6 to F7 Restart Hangs Both Ways
When I logout and do a restart to boot from one OS to the other the computer
hangs after selecting the OS in Grub. If I shut down and then start up I have no
problem. 
This does not happen if I restart and select the older kernel versions.

Version-Release number of selected component (if applicable):
vmlinuz-2.6.22.1-33.fc7
vmlinuz-2.6.22.1-32.fc6


How reproducible:

Every restart into these kernels.

Additional info:
# Relevant lines in Grub Below:

#boot=/dev/hda
default=0
timeout=8
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
# hiddenmenu


title Fedora Core (2.6.22.1-32.fc6)
root (hd0,0)
kernel /boot/vmlinuz-2.6.22.1-32.fc6 ro root=LABEL=/12 iommu=noaperture rhgb quiet
initrd /boot/initrd-2.6.22.1-32.fc6.img

title Fedora Core (2.6.20-1.2962.fc6)
root (hd0,0)
kernel /boot/vmlinuz-2.6.20-1.2962.fc6 ro root=LABEL=/12 iommu=noaperture rhgb quiet
initrd /boot/initrd-2.6.20-1.2962.fc6.img

title F7 Latest
root (hd0,6)
kernel /boot/vmlinuz-2.6.22.1-33.fc7 ro root=LABEL=/1 rhgb quiet iommu=noaperture
initrd /boot/initrd-2.6.22.1-33.fc7.img

title F7
root (hd0,6)
kernel /boot/vmlinuz-2.6.21-1.3194.fc7 ro root=LABEL=/1 rhgb quiet iommu=noaperture
initrd /boot/initrd-2.6.21-1.3194.fc7.img
################################################## #############3

The panic screen lists what I believe are memory registers with hex content.
Also a list of library files. I will try to transcribe this when I next reboot.
Comment 1 Kelly-Rand 2007-08-19 09:28:35 EDT
I have since deduced that this is a problem specific to F7. This behavior on
restart is associated with the 2.6.22.1-33.fc7 kernel as it does not happen with
the prior kernel. I have discovered that the restart hang also occurs when you
restart F7 from this same kernel version, ie: lets say you update or change a
parameter that requires reboot to take effect.

Anyway I did copy down some lines from the panic screen.
##############################################
F7 kernel version = 2.6.22.1-33.fc7

kernel panic on restart, the following is transcribed from screen excluding
memory register addresses.

Call Trace:

[...]	pci_fixup_device+0x8c/0x9a
[...]	pci_init+0x12/0x2b
[...]	kernel_init+0x206/0x370
[...]	child_rip+0xa/0x12
[...]	acpi_ds_init_one_object+0x0/0x7c
[...]	kernel_init+0x0/0x370
[...]	child_rip+0x0/0x370

Code: 00 00 00 00 00 .............
RIP   [...] quirk_usb_early_handoff+0x0/0x385
RSP   <...>
CR2 0000000000

end of screen output
###################################################
Comment 2 Chuck Ebbert 2007-08-20 14:23:56 EDT
Please boot in 50-line mode (add vga=ask to the kernel command line, then select
80x50 mode) and take a picture of the screen with a digital camera. Attach that
to the bug report.
Comment 3 Kelly-Rand 2007-08-20 19:17:47 EDT
Created attachment 161935 [details]
Screen shot of boot error message

vga mode 80x50
As requested
Comment 4 Wojciech Kazubski 2007-09-24 05:47:35 EDT
I also have such problem on all 2.6.22 kernels, on my x86_64 machine. Other 
machines running i686 kernel work fine with each upgrade.
I have to use the last working kernel 2.6.21-1.3228.fc7.
Comment 5 Chuck Ebbert 2007-09-24 19:39:31 EDT
adding "reboot=cold" to the kernel command line should fix this but it's really
just a workaround.

Full list of reboot modes for i386:

  warm
  cold
  bios
  hard
  smp

x86_64:

  warm
  cold
  triple
  bios
  kbd
  force
Comment 6 Kelly-Rand 2007-09-24 22:14:55 EDT
My custom compiled kernel has no problem with restarts. It is based on the
2.6.22.1-33 kernel. 

Jim
Comment 7 Christopher Brown 2008-01-11 12:04:11 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 8 Kelly-Rand 2008-01-11 15:20:49 EST
This bug is no longer an issue for me. I am now using the 2.6.23.12-52 F7 kernel
and have no problems with reboot.
Comment 9 Christopher Brown 2008-01-11 16:13:07 EST
Great news - thanks for filing originally. Will close CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.