This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 252395 - RHEL 5 network configuration lost when moving removable drives
RHEL 5 network configuration lost when moving removable drives
Status: CLOSED DUPLICATE of bug 288441
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kudzu (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-15 15:20 EDT by Isaac W.
Modified: 2014-03-16 23:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 12:09:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Isaac W. 2007-08-15 15:20:20 EDT
Description of problem:
The network configuration is lost when a removable hard drive with RHEL 5 is 
moved from one computer to another.  Both computers are the same brand and 
model and are equipped with the same hardware.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install the RHEL 5 hard drive in computer #1.
2. Configure the Ethernet device with a static IP address.
3. Reboot computer #1 and note that the network configuration is maintained.
4. Remove hard drive and install in computer #2.
  
Actual results:
At boot, computer hangs with the message "Obtaining IP information" and later 
fails to start the network interface.

Expected results:
At worst, expect Kudzu to come up and ask to migrate the network 
configuration.  At best, expect all network settings to be maintained.

Additional info:

The original ifcfg-eth0 file looks like this:
DEVICE=eth0
BOOTPROTO=none
BROADCAST=192.5.10.255
IPADDR=192.5.10.1
NETMASK=255.255.255.0
NETWORK=192.5.10.0
USERCTL=no
ONBOOT=yes
TYPE=Ethernet

When the computer finally comes up, the ifcfg-eth0 file has been changed to 
this:
# Intel Corporation 8255xER/82551IT Fast Ethernet Controller
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=dhcp
HWADDR=00:20:ce:81:1b:50
Comment 3 Bill Nottingham 2008-05-05 12:09:47 EDT
This is changed in the upcoming RHEL 5.2 updates; the network configuration will
not be changed if there is no HWADDR in the config file.

*** This bug has been marked as a duplicate of 288441 ***

Note You need to log in before you can comment on or make changes to this bug.