Bug 252422 - kernel-2.6.22.1-32.fc6 USB/Serial device driver broken
kernel-2.6.22.1-32.fc6 USB/Serial device driver broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-15 21:28 EDT by Ian Laurie
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.6.22.2-42.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 17:14:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Laurie 2007-08-15 21:28:09 EDT
Description of problem:
I have been using an Edgeport USB/Serial adaptor and set RTS using this
code:

    bits = TIOCM_RTS;
    ioctl(GenInfo->fd, TIOCMBIS, &bits);    /* Assert RTS */

This has worked on all FC6 kernels up to and including kernel-2.6.20-1.2962.fc6.
I updated to kernel-2.6.22.1-32.fc6 yesterday and the above code no longer works
with the edgeport device driver.  The function call returns zero, but RTS does
not get asserted.

Version-Release number of selected component (if applicable):
kernel-2.6.22.1-32.fc6

How reproducible:
Always.

Steps to Reproduce:
1.  See code above.
2.
3.
  
Actual results:
Function returns zero but doesn't do anything.

Expected results:
RTS should be asserted as it was with previous kernels.

Additional info:
Comment 1 Chuck Ebbert 2007-08-16 13:31:32 EDT
This is apparently fixed by git commit bc71e479cdb2caab9b4473f7ad508c3fcb142486.
Will get in kernel as soon as possible but today's build is already running.
Comment 2 Chuck Ebbert 2007-08-16 13:37:12 EDT
Fix is in 2.6.22.2 already. Try 2.6.22.2-57 from the updates-testing repo, or
wait for the next kernel update.
Comment 3 Ian Laurie 2007-08-23 20:18:26 EDT
The kernel-2.6.22.2-42 update seems to have fixed it.

Note You need to log in before you can comment on or make changes to this bug.