Bug 25263 - RH7.0/apache 1.3.14/mod_auth_db could not open db auth file:
Summary: RH7.0/apache 1.3.14/mod_auth_db could not open db auth file:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-30 05:14 UTC by Max Eper
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-30 07:13:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Max Eper 2001-01-30 05:14:37 UTC
With RH7.0/Apache 1.3.14/mod_auth_db/perl5.6.0



apache complains:



[Mon Jan 29 21:29:48 2001] [error] [client 192.168.0.14] could not 

open db auth file: /var/www/testpw

[Mon Jan 29 21:29:48 2001] [error] [client 192.168.0.14] DB user 

testuser not found: /var/www/html/manual/index.html



An identical setup on LinuxPPC/Apache 1.3.14/mod_auth_db/perl 

5.005_03 works fine.



test case:



1) Change appropriate line of httpd.conf to: AllowOverride AuthConfig



2) Add an .htaccess file to /var/www/html/manual



AuthName "the test manual "

AuthType Basic

AuthDBUserFile /var/www/testpw

<Limit GET POST>

require valid-user

</Limit>



3) Run a perl script to create the database (dbmmanage works fine  

with this file, too)



#!/usr/bin/perl



use DB_File;

use vars qw( %h) ;



### crypt the password



   $salt = 'ab';



   $user     = 'testuser';

   $password = 'testuser';



   $crypt_password = crypt ($password, $salt);



   print  "user: $user\n";

   print  "cryted pw: $crypt_password\n\n";



### make the db



   tie %h, "DB_File", "/var/www/testpw", O_RDWR|O_CREAT, 0644, 

$DB_HASH

      or die "Cannot open file '/var/www/testpw': $!\n";



   $h{$user} = "$crypt_password" . ':groupinfo';



   print "Put into testpw $user -> $h{$user}\n\n";



   untie %h ;



print "Done\n";



4) I examined the file with dbmmanage and added another user just 

to be sure it worked.



4) Now try to access the password protected directory



Error log says:

[Mon Jan 29 21:29:48 2001] [error] [client 192.168.0.14] could not 

open db auth file: /var/www/testpw

[Mon Jan 29 21:29:48 2001] [error] [client 192.168.0.14] DB user 

testuser not found: /var/www/html/manual/index.html



Problem does not show up on the LinuxPPC box with the same 

configuration (but using perl 5.005_03)



Permissions & ownership are the same on each box.





I saw someone with the same problem on:



comp.infosystems.www.servers.unix



but no response that said the problem was fixed.



Let me know if you need more system info.



Thanks,



Max Eper

Comment 1 Nalin Dahyabhai 2001-01-30 06:06:04 UTC
We hit some weird linkage problems with httpd not too long ago.  Can you see if
this is still a problem with apache-1.3.14-8 or later from Raw Hide
(ftp://ftp.redhat.com/pub/rawhide/)?

Comment 2 Max Eper 2001-01-30 07:13:09 UTC
Upgrading from apache-1.3.14-3 to apache-1.3.14-8 (along with several 
cascading dependencies - initscripts, gettext, ypbind) solved the problem.

I had gotten apache 1.3.14-3 from the updates/errata section.

Thanks for the quick response.



Comment 3 Nalin Dahyabhai 2001-01-30 09:05:48 UTC
I'll resolve this as fixed in Raw Hide, then.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.