Bug 25265 - Aztech Sound Galaxy
Aztech Sound Galaxy
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
7.0J
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-30 00:43 EST by Estevam Alves Moreira Neto
Modified: 2014-03-16 22:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-30 19:36:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Estevam Alves Moreira Neto 2001-01-30 00:43:36 EST
Sndconfig doesn't install Aztech Sound Galaxy cards, because the options are incorrect. The correct options are:
IO Port: 0x220, 0x240
WSS IO Port: 0x530, 0xe80, 0xf40, 0x604
IRQ: 7, 9, 10, 11
Firts DMA: 0, 1, 3
Max. Firts DMA Size In KB: 8, 16, 32, 64

These options are from ALSACONF.
Comment 1 Bill Nottingham 2001-01-30 12:54:05 EST
As I said, that last parameter is completely bogus for the standard
kernel drivers.

What parameter do you need to set that it doesn't offer, and
what does a working /etc/modules.conf look like for you?
Comment 2 Estevam Alves Moreira Neto 2001-01-30 19:31:42 EST
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 0.4.3b ---
alias char-major-116 snd
alias snd-card-0 snd-card-sgalaxy
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
options snd snd_major=116 snd_cards_limit=1 snd_device_mode=0660 snd_device_gid=29 snd_device_uid=0
options snd-card-sgalaxy snd_index=0 snd_id=CARD_0 snd_sbport=0x220 snd_wssport=0xf40 snd_irq=9 snd_dma1=1 snd_dma1_size=16
# --- END: Generated by ALSACONF, do not edit. ---
Comment 3 Bill Nottingham 2001-01-30 19:36:09 EST
A modules.conf that uses ALSA doesn't tell me much; sndconfig doesn't handle ALSA.
Comment 4 Bill Nottingham 2002-01-23 01:27:21 EST
closing, lack of response.

Note You need to log in before you can comment on or make changes to this bug.