This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 25270 - uptime resets after aproximately 500 days
uptime resets after aproximately 500 days
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
www.hal.si
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-30 03:51 EST by Marko Hrastovec
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-30 03:51:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marko Hrastovec 2001-01-30 03:51:41 EST
Kernel keeps the number of seconds about uptime. The numbers
can be found in /proc/uptime.

In kernel source uptime variable is declared as long.
(include/linux/kernel.h)

After cca. 500 days the counter resets because of overflow.
Uptime in seconds needs larger number type.
Comment 1 Michael K. Johnson 2001-01-30 16:30:16 EST
This is by design; uptime has to be atomically updated.  Changing this
gets proposed over and over on linux-kernel, and is repeatedly rejected
for the same reason.

Note You need to log in before you can comment on or make changes to this bug.