Bug 25297 - radeon problems
radeon problems
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Florence RC-1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-30 09:17 EST by Chris Runge
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-12 15:35:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Runge 2001-01-30 09:17:00 EST
beta3 (fisher)

graphical install using NFS

at the X Configuration screen I run into several problems:

doesn't autodetect Radeon
no option to specify 64 MB of video RAM
no 32-bit color option?
1024x768x24 -- click test -- screen blacks out and doesn't return -- hard
reset req'd

System setup:
Supermicro 370DE6 motherboard (based on ServerWorks III HE-SL chipset)
dual P3 1GHz
ATI Radeon VIVO 64 DDR
512 MB RAM

marking as severe/high priority due to the problem with the test hanging
the machine
Comment 1 Michael Fulbright 2001-01-30 12:42:54 EST
assigning to a developer.
Comment 2 Brent Fox 2001-01-30 13:27:51 EST
I have a 32 MB Radeon in my test machine.  Although it is not probed properly, I
can select it from the video card list.  The installer probes the 32 MB of
memory correctly, though.  In the X configuration screen, I can test the card
without it hanging.  I'm guessing that your problems are related to having 64 MB
of memory, whereas my card has 32.  I'm working on getting a 64 MB card.  Ok,
here's a few issues:
1) ATI Radeon is not detected by the PCI id.  This is now fixed in internal
builds.  The Radeon pci id (1002:5144) has been added to the pci table.
2) The installer does not currently detect over 32MB of video memory.  I'm
working on this.

I'm still trying to figure out why your card hangs.  Did you select it in the
card list after it wasn't detected?  Also, what did the ram say?  Did you pick
32MB of ram?
Comment 3 Chris Runge 2001-01-30 14:22:25 EST
I did select the RAM (chose 32 MB) and the Radeon VIVO 64 selection.
RAM (as probed?) was 256K, I believe.

I wonder if this is a motherboard AGP chipset support problem? The chipset is
fairly new...
Comment 4 Chris Runge 2001-01-30 14:27:05 EST
some more info from 25299 (where startx hangs the machine post-install):

# modprobe agpgart
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/agp/agpgart.o: init_module: No
such device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/agp/agpgart.o: insmod
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/agp/agpgart.o failed
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/agp/agpgart.o: insmod agpgart
failed
[root@rockne agp]# modprobe radeon
[drm:radeon_init] *ERROR* Cannot initialize agpgart module.
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/drm/radeon.o: init_module:
Cannot allocate memory
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/drm/radeon.o: insmod
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/drm/radeon.o failed
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/drm/radeon.o: insmod radeon
failed


from dmesg:

Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: no supported devices found.
[drm:radeon_init] *ERROR* Cannot initialize agpgart module.


from lspci -v:

01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device 5144
(prog-if 00 [VGA])
        Subsystem: ATI Technologies Inc: Unknown device 001a
        Flags: bus master, stepping, 66Mhz, medium devsel, latency 64, IRQ 30
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at c800 [size=256]
        Memory at fe780000 (32-bit, non-prefetchable) [size=512K]
        Expansion ROM at fe760000 [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2
Comment 5 Glen Foster 2001-01-30 15:43:48 EST
This defect is considered MUST-FIX for Florence Release-Candidate #1
Comment 6 Brent Fox 2001-01-30 16:56:56 EST
We have ordered a 64MB Radeon that should be here within a week.  I can't do
much more until then, so I'm putting the bug in NEEDINFO state.  I'll revisit
this when the card arrives.
Comment 7 Brent Fox 2001-02-05 16:38:48 EST
Radeon card has arrived.  Resuming testing.
Comment 8 Brent Fox 2001-02-06 13:56:51 EST
Ok, the installer now probes the card and correctly selects 64MB of video
memory.  Testing the card at certain resolutions still causes a lockup.  I'm
inclined to think that this is now an X server problem.  When you are testing
the card, the X framebuffer server is running.  Pressing the test button causes
another X server to start (XFree 4 in this case).  I think that XFree 4 has a
problem when more than one X server is running.  I'll test this further.
Comment 9 Mike A. Harris 2001-02-07 00:50:33 EST
I have been running a 64Mb Radeon, as well as a 32Mb one for over a month
with zero problems.  No DRI, no framebuffer.  These problems are not
replicable with any of my cards here.
Comment 10 Brent Fox 2001-02-07 13:47:43 EST
Mike, can you try installing Fisher and testing the X configuration on the 64MB
Radeon?  Testing at 16 bit 1024x768 is fine, but if I test at 16bit 1152x864,
the X server starts and then the machine locks.  No keyboard, no mouse.  See if
this happens for you.
Comment 11 Brent Fox 2001-02-12 15:35:11 EST
This seems to be fixed now.  I think on some machines, we were running out of
memory.  This would explain why testing at resolutions 1024x768 or lower would
work, while resolutions higher would fail.  Although now I'm seeing another
problem...if you test at 1152x864, the X server starts at 1280x1024...although
the XF86Config file says 1152x864.  Very weird.  That's a separate issue,
though, and I'm resolving this bug since the lockup problem is fixed.  Brock,
please verify.  I have a Radeon card I can lend you.

Note You need to log in before you can comment on or make changes to this bug.