Bug 252973 - halt script incompatible with the new nut-2.2.0
Summary: halt script incompatible with the new nut-2.2.0
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-16 12:48 UTC by Tomas Smetana
Modified: 2014-03-17 03:08 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-08-30 17:41:51 UTC


Attachments (Terms of Use)
proposed patch (797 bytes, patch)
2007-08-16 12:48 UTC, Tomas Smetana
no flags Details | Diff

Description Tomas Smetana 2007-08-16 12:48:22 UTC
Hi,
  the new version of NUT (network ups tools) brings some changes that affect the
halt script:
* the $MODEL variable is not set in /etc/sysconfig/ups
* the powerdown flag file is configurable via $POWERDOWNFLAG variable
* the particular drivers should not be called directly and /sbin/upsdrvctl
should be used instead to invoke drivers' shutdown sequence

I'm attaching a patch that shows the required changes.  Please update the halt
script to be compatible with the new NUT package.

Comment 1 Tomas Smetana 2007-08-16 12:48:22 UTC
Created attachment 161648 [details]
proposed patch

Comment 2 Bill Nottingham 2007-08-29 17:27:44 UTC
Does this mean I'll need to conflict with older nut packages? (I assume so.)

Comment 3 Tomas Smetana 2007-08-30 06:15:33 UTC
Yes.  This change should not appear in earlier versions (F-7 and older).

Comment 4 Bill Nottingham 2007-08-30 17:41:51 UTC
Fixed in 8.56-1.


Note You need to log in before you can comment on or make changes to this bug.