Bug 252977 - Anaconda unhandled exception error trying to create LVM partitions
Anaconda unhandled exception error trying to create LVM partitions
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-16 08:59 EDT by Giuliano Marco
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 13:15:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giuliano Marco 2007-08-16 08:59:46 EDT
Description of problem:

Anaconda unhandled exception occurred.

While attempting to installing Fedora 8 Test 1 (64-bit DVD), I thought I'd try
out the LVM manager. After selecting "Create Custom Layout" I tried sub-dividing
a 25600MB logical partition (sda11, on a 320GB WD SATA drive, previously
formatted as ReiserFS with PCLinuxOS installed) into four logical volumes. After
click on [Edit], the type was listed as LVM PV, and the format column was
checked. After clicking on [LVM], the following table was created:

VolGroup00
Phys. Ext. 32MB (default)
sda11 25600

Log.Vol.   Mount Pt.   Size (MB)
LogVol00   /boot       128MB (ext2)
LogVol01   /           12128MB (ext3)
LogVol02   swap        3072 (swap)
LogVol03   /home       10240 (ext3)

The above appeared in the LVM groups list at the top, and everything appeared OK
until I pressed [NEXT] to commit the changes. Then the unhandled exception error
occurred. Which repeated itself in exactly the same manner when I tried a second
time, after rebooting.

How reproducible:

Follow the above steps.

Additional info:

(There is no facility to cut-and-paste at this point in Anaconda, so I will type
in the top-most portion of the lengthy error report).

------------------------------------------------------------------------------
Exception details:
Traceback (most recent call first):
File "/usr/lib/anaconda/fsset.py", line 2834, in getDiskPart
  if name[-1]='p':
File "/usr/lib/anaconda/partitions.py", line 861, in sanityCheckAllRequests
  (dev, num)=fsset.getDiskPart(br.device)
File "/usr/lib/anaconda/iw/partition_gui.py", line 630, in getNext
  (errors, warnings)=self.partitions.sanityCheckAllRequests(self.diskset)
File "/usr/lib/anaconda/gui.py", line 1043, in nextClicked
  rc=self.currentWindow.getNext()
IndexError: string index out of range

Local variables in innermost frame:
cut: -2
name:
dev: 18
------------------------------------------------------------------------------

After deleting sda11 (with a GPartEd boot CD), I created it again as a single
25,600MB ext3 logical partition. I also ran a check against it, which was clean.

I followed exactly the same procedure for a third time, and like before crashed
with an exception error when I pressed [Next] to commit the changes (so it can't
have been solely due to the partition being formerly formatted as ReiserFS).

I will attempt to repeat the procedure in a VMware session, which will hopefully
let me take a snapshot of the entire error message, so I can append it here.
Comment 1 Giuliano Marco 2007-08-16 09:15:48 EDT
Unfortunately it seems I can't cut-and-paste from VMware at that point, either.
But I did manage to reproduce exactly the same error with it. I created a .vmx
file (with a single 25GB disk#1 IDE) by using the virtual machine creator at
www.easyvmx.com, and selecting the EasyVMX! 2.0 (beta) generator.

I set it up this time as a single primary partition, set it to LVM, then
sub-divided it into four LVM logical partitions as before. Same exception error
as soon as I press [Next].
Comment 2 Giuliano Marco 2007-08-16 13:15:06 EDT
Apologies - I've just found out you're not supposed to include a /boot partition
inside an LVM. It has to remain outside, in a standard ext2/3 partition of it's own.

But as that's the case, it would be a good idea if Anaconda warned you about it,
instead of just accepting it then crashing out with an error.

Note You need to log in before you can comment on or make changes to this bug.