Bug 252979 - RPM missing a Requires:, fails on too-old glibc
Summary: RPM missing a Requires:, fails on too-old glibc
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-16 13:07 UTC by Valdis Kletnieks
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 07:36:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Valdis Kletnieks 2007-08-16 13:07:31 UTC
Description of problem:
RPM and yum loop with an error message:
rpmdb: unable to lock mutex: Invalid argument

I have glibc-2.6.90-8 installed, apparently rpm-libs is trying to use the futex
support added in 2.6.90-9.

Version-Release number of selected component (if applicable):
rpm-4.4.2.1-7.fc8

How reproducible:
Install this release of RPM and a glibc older than 2.6.90-9.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Valdis Kletnieks 2007-08-16 14:20:52 UTC
Something else is obviously squirrelly - I managed to get back to an older RPM
with 'rpm2cpio rpm-4.4.2.1-6.x86_64.rpm | cpio -ivudm' and it's still doing it.

Comment 2 Valdis Kletnieks 2007-08-16 14:40:57 UTC
Whatever it was, seems to be gone after applying glibc-2.6.90-10.  Also, it only
seems to trigger if /var/lib/rpm/__db.00* files are present (hand-removing them
make it shut up).

Comment 3 Panu Matilainen 2007-08-20 07:36:53 UTC
Looks like temporary glibc brokenness, rpm mostly just cares about having
working and compatible NPTL used for locking (the __db* files). glibc 2.6.90 is
most certainly new enough, too new if anything... :)


Note You need to log in before you can comment on or make changes to this bug.