Bug 25299 - startx hangs system and places monitor into power-save mode
Summary: startx hangs system and places monitor into power-save mode
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-30 14:25 UTC by Chris Runge
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-03 20:09:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Runge 2001-01-30 14:25:24 UTC
beta 3 (fisher)

When I startx the monitor goes into power save mode and the system must be
issued a hard reset.

I have the following setup:
- ATI Radeon VIVO 64
- SuperMicro 370DE6 motherboard, based on ServerWorks III HE-SL chipset
- 512 MB of RAM
- dual P3 1GHz processors

I think this may be related to problem 25297--there testing the Radeon
during a graphical
install also hung the system (but did not place the monitor into power-save
mode). After encountering that problem I did a fresh install but did not
test the video)--I did check the /etc/XF86Config-4 file before starting X
and it did look okay, however.

See also 25298 for a problem with Radeon during the text installer.

Comment 1 Chris Runge 2001-01-30 19:25:50 UTC
after rebooting I noticed that the agpgart and radeon modules weren't loaded...
loading them gives this error:

# modprobe agpgart
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/agp/agpgart.o: init_module: No
such device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/agp/agpgart.o: insmod
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/agp/agpgart.o failed
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/agp/agpgart.o: insmod agpgart
failed
[root@rockne agp]# modprobe radeon
[drm:radeon_init] *ERROR* Cannot initialize agpgart module.
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/drm/radeon.o: init_module:
Cannot allocate memory
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/drm/radeon.o: insmod
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/drm/radeon.o failed
/lib/modules/2.4.0-0.99.11smp/kernel/drivers/char/drm/radeon.o: insmod radeon
failed



some more info....

from dmesg:

Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: no supported devices found.
[drm:radeon_init] *ERROR* Cannot initialize agpgart module.


from lspci -v:

01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device 5144
(prog-if 00 [VGA])
        Subsystem: ATI Technologies Inc: Unknown device 001a
        Flags: bus master, stepping, 66Mhz, medium devsel, latency 64, IRQ 30
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at c800 [size=256]
        Memory at fe780000 (32-bit, non-prefetchable) [size=512K]
        Expansion ROM at fe760000 [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2


Comment 2 Michael K. Johnson 2001-07-03 20:09:14 UTC
Looking through old bugs, saw that this one didn't get dealt with earlier.
Is this still a problem with Red Hat Linux 7.1?


Note You need to log in before you can comment on or make changes to this bug.