Bug 253016 - gfs2_quota: userland changes for bz 235299 (do_list operation hangs)
gfs2_quota: userland changes for bz 235299 (do_list operation hangs)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs2-utils (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Abhijith Das
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-16 13:07 EDT by Abhijith Das
Modified: 2010-01-11 22:39 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0579
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 13:05:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Abhijith Das 2007-08-16 13:07:39 EDT
The fix to bz 235299 is two part, one the kernel (gfs2 filesystem) and another
in the userland bits (gfs2_quota and libgfs2). bz 235299 is for the kernel fix
and this bz tracks the userland fixes.

Description of problem: (copied from bz 235299)
gfs_quota list -f /fs/path appears to hang when the hidden quota file becomes an
unmanageably large sparse file. Clone of RHEL4 bug 210362 and RHEL5 gfs1 bug 225199.

The gfs_quota tool sequentially reads the quota file ignorant of large holes in
the quota file which takes a lot of time. The gfs_quota tool needs to
intelligently skip the holes in the file and only read quota file information
that's on actual data-filled blocks.

Because ioctls have been removed from GFS2, the solution to this has to be
different than what's been done for gfs1 in RHEL4 and RHEL5.
Comment 1 Abhijith Das 2007-08-24 02:10:37 EDT
Committed fix to cvs HEAD, RHEL5 and RHEL51
Comment 4 errata-xmlrpc 2007-11-07 13:05:18 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0579.html
Comment 5 Fedora Update System 2008-12-10 15:44:13 EST
eclipse-changelog-2.6.4-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/eclipse-changelog-2.6.4-1.fc10

Note You need to log in before you can comment on or make changes to this bug.