Bug 253045 - Need a symbol in ia64 whitelist for RHEL5.1 PV-on-HVM drivers
Summary: Need a symbol in ia64 whitelist for RHEL5.1 PV-on-HVM drivers
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: driver-update-program   
(Show other bugs)
Version: 5.1
Hardware: ia64
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Jon Masters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-16 18:39 UTC by Keiichiro Tokunaga
Modified: 2013-07-04 23:49 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 17:02:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xenpv package fix. (1.12 KB, text/x-patch)
2007-08-17 09:28 UTC, Gerd Hoffmann
no flags Details

Description Keiichiro Tokunaga 2007-08-16 18:39:16 UTC
Description of problem:
RHEL5.1 PV-on-HVM drivers packages installation fails due to a dependency 
issue.

# rpm -ihv kmod-xenpv-3.1_15042-22.el5.ia64.rpm xenpv-3.1_15042-22.el5.ia64.rpm
error: Failed dependencies:
        ksym(isa_irq_to_vector_map) = 3aed7527 is needed by kmod-xenpv-
3.1_15042-22.el5.ia64

Version-Release number of selected component (if applicable):
RHEL5.1 Snapshot2 with the following PV-on-HVM drivers provided separately.

  - xenpv-3.1_15042-22.el5.ia64.rpm
  - kmod-xenpv-3.1_15042-22.el5.ia64.rpm

How reproducible:
Always.

Steps to Reproduce:
1. Install the packages using "rpm -ihv"
  
Actual results:
Installation fails.

Expected results:
Installation completes successfully.

Additional info:
isa_irq_to_vector_map needs to be added to the ia64 whitelist.

Comment 2 Stephen Tweedie 2007-08-16 19:50:18 UTC
Is there any more of an explanation why we need this?  "isa_irq_to_vector_map"
sounds very low-level for Xen drivers to be playing with.


Comment 3 Gerd Hoffmann 2007-08-17 09:28:11 UTC
Created attachment 161724 [details]
xenpv package fix.

.23 builds with the patch included available, please test.

I think we don't need that.  Xen just wants to know whenever the irq in
question is an ISA irq or not.	We don't need the map for that, just checking
the range (0x20 ->0x2f) is good enougth for that.

Comment 4 Gerd Hoffmann 2007-08-17 09:31:14 UTC
Please test whenever the new packages work without the symbol export.

Comment 5 Keiichiro Tokunaga 2007-08-21 16:55:15 UTC
I tested -23 on my box running snapshot1.  The installation of the packages
completed successfully without any dependency messages.

Thanks!

Comment 6 Gerd Hoffmann 2007-08-21 17:02:10 UTC
So we don't need the symbol, great!


Note You need to log in before you can comment on or make changes to this bug.