Bug 253088 - [RFE] Add support for Wacom PTZ-431W to kernel
[RFE] Add support for Wacom PTZ-431W to kernel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: wdaemon (Show other bugs)
4.5
All Linux
medium Severity low
: ---
: ---
Assigned To: Aristeu Rozanski
desktop-bugs@redhat.com
:
Depends On:
Blocks: 370471 RHEL4u7_relnotes
  Show dependency treegraph
 
Reported: 2007-08-16 17:24 EDT by Charlie Wyse
Modified: 2008-07-24 15:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0722
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:57:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test patch (11.20 KB, patch)
2007-08-20 10:55 EDT, Aristeu Rozanski
no flags Details | Diff
Xorg.conf file (2.89 KB, text/plain)
2008-03-25 14:52 EDT, Charlie Wyse
no flags Details

  None (edit)
Description Charlie Wyse 2007-08-16 17:24:27 EDT
Description of problem:
Currently RHEL 4 and 5 do not support the Wacom mini tablet PTZ-431W.  It
appears to work in Fedora 6 kernel 2.6.22-1-32


Version-Release number of selected component (if applicable):
linuxwacom-0.7.8-2
Comment 3 Aristeu Rozanski 2007-08-20 10:55:42 EDT
Created attachment 161887 [details]
test patch

Please apply this patch and report how it goes.
Comment 6 Aristeu Rozanski 2007-08-21 14:56:26 EDT
Charlie, about the kbd issue, see the comment I added on that BZ#.
About the wacom stuff, will be queued for the next RHEL-4 version (4.7) along with
other changes.
This kernel solved all the problems with this tablet? All the features are working
ok?
Comment 7 Aristeu Rozanski 2008-01-07 11:37:51 EST
Charlie, did you tried the test packages?
if not:
http://people.redhat.com/arozansk/wacom/

please test and tell me how it goes

Thanks
Comment 8 Charlie Wyse 2008-01-29 14:51:23 EST
Okay, I got some hardware so I can begin testing again.  I downloaded the 55 and
the 65 kernel from the link provided.  Neither of them seem to work in absolute
mode.  I added `Options "Mode" "Absolute"` to all wacom devices.  But that
didn't seem to improve anything.
Comment 9 Aristeu Rozanski 2008-01-29 15:01:46 EST
did you installed the linuxwacom package too?
Comment 10 Charlie Wyse 2008-01-30 14:40:16 EST
Correct, even the wdaemon packages.
Comment 13 Aristeu Rozanski 2008-02-07 10:53:55 EST
Charlie,
(In reply to comment #0)
> Description of problem:
> Currently RHEL 4 and 5 do not support the Wacom mini tablet PTZ-431W.  It
> appears to work in Fedora 6 kernel 2.6.22-1-32
did you tested the packages with PTZ-431W too?

Comment 14 Charlie Wyse 2008-02-08 19:36:34 EST
Yes, it appears to work beautifully.
Comment 15 RHEL Product and Program Management 2008-02-14 12:38:39 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 22 Aristeu Rozanski 2008-02-28 14:55:30 EST
Charlie, the required patches will be on RHEL4.7 kernel and the needed packages
will be also on RHEL4.7.
Will be possible to them to update to RHEL4.7 when it's out?
Comment 29 Vivek Goyal 2008-03-18 12:00:52 EDT
Committed in 68.22.EL. Released in 68.23.EL. RPMS are available at http://people.redhat.com/vgoyal/rhel4/
Comment 31 Charlie Wyse 2008-03-25 14:52:32 EDT
Created attachment 299057 [details]
Xorg.conf file
Comment 32 Charlie Wyse 2008-03-25 14:54:33 EDT
Hrm, I was hoping I could attach that and send a message.  Okay, so wdaemon is
chkconfig to on.  However on boot it doesn't say fail it just goes on like it
worked.  Then we find the daemon isn't running and try to restart it twice. 
Here is the current software versions I am running.
cwyse@unbridled [:~] % rpm -q wdaemon linuxwacom; uname -r                     
                                                                  [11:50:45]
wdaemon-0.14-2.el4
linuxwacom-0.7.8.3-3.el4
2.6.9-67.EL.wacom

Also here is my wdaemon.conf 
device = 41,/dev/input/wacom-tablets/cintiq21ux-tablet
Comment 33 Aristeu Rozanski 2008-03-25 15:01:36 EDT
Hi Charlie,
thanks for the info. It's strange because:
   Mar 21 13:52:57 doerun wdaemon: Unable to grab device
/dev/input/wacom-tablets/cintiq21ux-tablet (Device or resource busy)

this message means something else is grabbing the device and the usual components
that do that are wdaemon or xorg wacom driver. anyway, wdaemon must be more
robust on those cases (keep trying to grab the device instead of just giving up
after some tries)
Comment 34 Aristeu Rozanski 2008-03-26 18:13:48 EDT
Charlie,
can you try running the debug wdaemon RPM that I uploaded to
  http://people.redhat.com/arozansk/wacom/
please?
upgrade using it, then reboot the machine. It'll create a /tmp/wdaemon.log. Please
send me this log after the machine finishing booting.
Thanks
Comment 35 Charlie Wyse 2008-03-31 20:36:56 EDT
Okay it doesn't create the /tmp/wdaemon.log file.  But it does look like the
error is from /dev/uinput not being created by the time wdaemon runs.  Also,
this problems seems to happen every other reboot or two.  So it's not
persistent.   Here are some commands I ran right after reboot.

cwyse@unbridled [:~] % rpm -q wdaemon linuxwacom                               
                                                                  [17:33:09]
wdaemon-0.14-1.el4.debug
linuxwacom-0.7.8.3-3.el4
cwyse@unbridled [:~] % uname -r                                                
                                                                  [17:33:34]
2.6.9-67.EL.wacom
cwyse@unbridled [:~] % ls -l /tmp/wdaemon.log                                  
                                                                  [17:33:38]
ls: /tmp/wdaemon.log: No such file or directory
cwyse@unbridled [:~] % tail -50 /var/log/al                                    
                                                                  [17:33:50]
all      all.all  
cwyse@unbridled [:~] % tail -50 /var/log/all.all | grep wdaemon                
                                                                  [17:33:50]
Mar 31 17:30:47 unbridled wdaemon:  succeeded
Mar 31 17:30:47 unbridled wdaemon: wdaemon version 0.14
Mar 31 17:30:47 unbridled wdaemon: Setting debug level to 2
Mar 31 17:30:47 unbridled wdaemon: Did 2 conversions
Mar 31 17:30:47 unbridled wdaemon: Got key [device], value
[41,/dev/input/wacom-tablets/cintiq21ux-tablet]
Mar 31 17:30:47 unbridled wdaemon: Got device type 41 and filename
/dev/input/wacom-tablets/cintiq21ux-tablet
Mar 31 17:30:47 unbridled wdaemon: hotplug_add_file: added directory
/dev/input/wacom-tablets
Mar 31 17:30:47 unbridled wdaemon: Unable to open uinput file /dev/uinput: No
such file or directoryError adding device
Mar 31 17:30:47 unbridled wdaemon: wdaemon startup failed
cwyse@unbridled [:~] % sudo service wdaemon status                             
                                                                  [17:34:03]
wdaemon is stopped
Comment 36 Aristeu Rozanski 2008-03-31 20:46:17 EDT
(In reply to comment #35)
> Okay it doesn't create the /tmp/wdaemon.log file.  But it does look like the
> error is from /dev/uinput not being created by the time wdaemon runs.  Also,
> this problems seems to happen every other reboot or two.  So it's not
> persistent.   Here are some commands I ran right after reboot.
(snip)

> Mar 31 17:30:47 unbridled wdaemon: Unable to open uinput file /dev/uinput: No
> such file or directoryError adding device
> Mar 31 17:30:47 unbridled wdaemon: wdaemon startup failed
> cwyse@unbridled [:~] % sudo service wdaemon status                             
great catch Charlie! thanks, I'll fix this as first thing tomorrow morning.
Comment 37 Aristeu Rozanski 2008-04-02 18:07:39 EDT
Charlie,
the new wdaemon package is available at
http://people.redhat.com/arozansk/wacom/
please test it. it'll fix the initialization problem.
Also, notice that this version will be in RHEL4.7, so if you find any
problems, let me know ASAP.
Comment 38 Charlie Wyse 2008-04-02 20:39:30 EDT
I just installed it and booted my machine 5 times in a row and wdaemon seems to
have started with no problems. I put the package in an update tree and let the
other people using cintiqs know where to get it so they will be helping me test
it out some time tomorrow, hopefully.  But everything looks good so far, I'll
let you know of something changes.  Thanks.
Comment 41 Don Domingo 2008-05-14 21:07:34 EDT
added to RHEL4.7 Driver Updates:

<quote>
wacom: driver updated to add support for the following input devices:

    * Intuos3 12x19
    * Intuos3 12x12
    * Intuos3 4x6
    * Cintiq 20wsx
</quote>

please advise if any further revisions are required. thanks!
Comment 42 Don Domingo 2008-06-02 19:13:51 EDT
Hi,

the RHEL4.7 release notes deadline is on June 17, 2008 (Tuesday). they will
undergo a final proofread before being dropped to translation, at which point no
further additions or revisions will be entertained.

a mockup of the RHEL4.7 release notes can be viewed here:
http://intranet.corp.redhat.com/ic/intranet/RHEL4u7relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don
Comment 46 errata-xmlrpc 2008-07-24 15:57:26 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0722.html

Note You need to log in before you can comment on or make changes to this bug.