Bug 253090 - Trash doesn't work on AFS filesystems
Summary: Trash doesn't work on AFS filesystems
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-vfs2   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Tomáš Bžatek
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 807971
TreeView+ depends on / blocked
 
Reported: 2007-08-16 21:30 UTC by Jack Neely
Modified: 2015-03-03 22:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-24 12:20:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Enable Trash on AFS filesystems (744 bytes, patch)
2007-08-16 21:40 UTC, Jack Neely
no flags Details | Diff

Description Jack Neely 2007-08-16 21:30:53 UTC
Description of problem:

Here at NCSU all home directories are in AFS.  I received a bug report
today that some users were having trouble with the Trash functionality
on the Gnome desktop.  You can drag stuff into Trash and the files are
magically transported to ~/.Trash as expected.  However, the Trash icon
never appears "full", opening Trash always shows you that its empty.
You cannot select Empty Trash.  The users' quota fills up, and they
don't know where the stuff the Trash'd has gone.

Turns out in line 40 in gnome-vfs-filesystem-type.c in the gnome-vfs2
package the Trash functionality is specifically turned off for AFS.

Is there a specific reason for this?  Can this be turned on upstream?

Version-Release number of selected component (if applicable):
gnome-vfs2-2.16.2-4.el5

This bug is similar to Bug #159652 and
https://bugs.launchpad.net/ubuntu/+source/gnome-applets/+bug/34247

Comment 1 Jack Neely 2007-08-16 21:40:07 UTC
Created attachment 161696 [details]
Enable Trash on AFS filesystems

Comment 2 RHEL Product and Program Management 2011-09-23 00:29:55 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 4 RHEL Product and Program Management 2012-04-02 10:34:15 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 5 Vladimir Benes 2012-04-23 14:23:10 UTC
Hi,
can you still reproduce on current 5.8 system? As gvfs was tuned a lot of times and most other bugs connected to trash are unreproducible. Could you please verify that this bug still exists?

thanks,
Vladimir

Comment 6 Jack Neely 2012-04-23 17:19:51 UTC
Vladimir,

At this point I think the issue is moot.  We've moved most of our desktop/workstation systems to RHEL 6 and the gvfs Trash functionality works well there.

So this bug can be closed.  However, I must say that I'm not pleased with an almost 5 year turn around on this bug especially when I attached patches to address this issue.

Jack Neely

Comment 7 Vladimir Benes 2012-04-24 12:20:37 UTC
(In reply to comment #6)
> Vladimir,
> 
> At this point I think the issue is moot.  We've moved most of our
> desktop/workstation systems to RHEL 6 and the gvfs Trash functionality works
> well there.
> 
> So this bug can be closed.  However, I must say that I'm not pleased with an
> almost 5 year turn around on this bug especially when I attached patches to
> address this issue.
> 
> Jack Neely

yes, I agree that fixing this bug was a total failure, this sh*t falls to PM heads. :-(

closing now, thanks,
Vladimir


Note You need to log in before you can comment on or make changes to this bug.