Bug 253125 - broken libcurses.so
broken libcurses.so
Status: CLOSED DUPLICATE of bug 228891
Product: Fedora
Classification: Fedora
Component: ncurses (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-16 20:25 EDT by John Ellson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 08:56:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2007-08-16 20:25:43 EDT
Description of problem:
/usr/lib64/libcurses.so isn't a shared library.  It contains
just the text:  INPUT(-lncurses)

$ ls -l /usr/lib64/libcurses.so
-rw-r--r-- 1 root root 17 2007-08-13 08:21 /usr/lib64/libcurses.so
$ ls -l /usr/lib64/libncurses.so.5
lrwxrwxrwx 1 root root 12 2006-12-24 17:06 /usr/lib64/libncurses.so.5 ->
libcurses.so
$ cat /usr/lib64/libncurses.so.5
INPUT(-lncurses)

Version-Release number of selected component (if applicable):
ncurses-devel-5.6-8.20070812.fc8.x86_64


How reproducible:
100%

Steps to Reproduce:
1. gdb /usr/bin/true
2.
3.
  
Actual results:
gdb: error while loading shared libraries: /usr/lib64/libncurses.so.5: file too
short

Expected results:
not that

Additional info:
Comment 1 Miroslav Lichvar 2007-08-17 06:54:07 EDT

*** This bug has been marked as a duplicate of 229737 ***
Comment 2 John Ellson 2007-08-17 08:35:20 EDT
But 229737 is marked as "won't fix" !!!

gdb and emacs are broken by curses on x86_64 and nobody plans to fix it ???
Comment 3 Miroslav Lichvar 2007-08-17 08:56:41 EDT

*** This bug has been marked as a duplicate of 228891 ***

Note You need to log in before you can comment on or make changes to this bug.