Bug 253136 - updatedb fails assertion
updatedb fails assertion
Status: CLOSED DUPLICATE of bug 242715
Product: Fedora
Classification: Fedora
Component: mlocate (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-17 00:40 EDT by David Robinson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 03:07:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Robinson 2007-08-17 00:40:43 EDT
Description of problem:
updatedb fails to run, it trips an assertion.

Version-Release number of selected component (if applicable):
Fedora release 7.90 (Rawhide)
mlocate-0.16-1

How reproducible:
100%

Steps to Reproduce:
1. run "updatedb" as root
  
Actual results:
updatedb: src/updatedb.c:721: scan_cwd: Asserion 'name_size > 1' failed.
Aborted

Expected results:
database is built.

Additional info:

#0  0x00002aaaaacf7895 in raise () from /lib64/libc.so.6
#1  0x00002aaaaacf9340 in abort () from /lib64/libc.so.6
#2  0x00002aaaaacf0c9f in __assert_fail () from /lib64/libc.so.6
#3  0x000000000040469d in scan (path=0x6133c0 "/sys/module/nousb/parameters",
cwd_fd=0x7fff7b3e93e8, st_parent=<value optimized out>, 
    relative=0x6121f9 "parameters") at src/updatedb.c:721
#4  0x0000000000403b6d in scan (path=<value optimized out>,
cwd_fd=0x7fff7b3ea5e8, st_parent=<value optimized out>, relative=0x611fb9 "nousb")
    at src/updatedb.c:545
#5  0x0000000000403b6d in scan (path=<value optimized out>,
cwd_fd=0x7fff7b3eb7e8, st_parent=<value optimized out>, relative=0x611579 "module")
    at src/updatedb.c:545
#6  0x0000000000403b6d in scan (path=<value optimized out>,
cwd_fd=0x7fff7b3ec9e8, st_parent=<value optimized out>, relative=0x611489 "sys")
    at src/updatedb.c:545
#7  0x0000000000403b6d in scan (path=<value optimized out>,
cwd_fd=0x7fff7b3edc6c, st_parent=<value optimized out>, relative=0x406a69 ".")
    at src/updatedb.c:545
#8  0x0000000000404ba5 in main (argc=<value optimized out>, argv=<value
optimized out>) at src/updatedb.c:965
#9  0x00002aaaaace4d58 in __libc_start_main () from /lib64/libc.so.6
#10 0x0000000000401c49 in _start ()
Comment 1 David Robinson 2007-08-17 01:01:41 EDT
hmmm, ok, this now working and I can't reproduce it. I was playing with
different gnome themes prior to the problem, now I've reverted back to the
default theme, closed xterm and reopened it, now updatedb is working... strange...
Comment 2 Miloslav Trmač 2007-08-17 03:07:13 EDT
Thanks for your report.  This bug is arelady tracked as #242715.

*** This bug has been marked as a duplicate of 242715 ***

Note You need to log in before you can comment on or make changes to this bug.