Bug 253147 - SMTP Authentication support
SMTP Authentication support
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-17 02:15 EDT by George Notaras
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 07:35:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch for mailman-2.1.9 (1.52 KB, patch)
2007-08-21 06:44 EDT, Tomas Smetana
no flags Details | Diff
SMTP Authentication with TLS support (not tested) (2.13 KB, patch)
2007-08-21 18:30 EDT, George Notaras
no flags Details | Diff

  None (edit)
Description George Notaras 2007-08-17 02:15:21 EDT
Description of problem:
This is not a bug report, but rather a feature request, which I wish it makes
its way upstream.

This software, although its biggest requirement is a SMTP service, it has not
been designed (SMTPdirect.py) to be able to use an SMTP server that requires
authentication.

This might sound like a feature that would be needed only by 'weird' email
server setups. However, taking into account the numerous currently implemented
unwanted/unnecessary/weird features in the mailman suite, one could say that
smtp auth would be by far more useful than many of those features.

Version-Release number of selected component (if applicable):
3:2.1.9-5
Comment 1 Tomas Smetana 2007-08-21 06:44:14 EDT
Created attachment 161960 [details]
A patch for mailman-2.1.9

Here's a patch that seems not to break anything (at least).  I don't know
whether a new feature would be accepted upstream since Mailman 3 is under
development and this is Mailman 2.  I'll try to test this and if it will work
I'll send it upstream.
Comment 2 George Notaras 2007-08-21 18:30:09 EDT
Created attachment 162017 [details]
SMTP Authentication with TLS support (not tested)

Tomas, thanks for the quick fix. I decided to build upon your patch and add
support for TLS connections, as many SMTP servers do not allow authentication
without establishing a TLS connection first.

I should mention that I have *not* tested the patch as I don't have a mailman
installation any more and I don't have the time to set Mailman for a test. I
had the code ready from another project of mine. I am sorry for submitting a
patch without testing it previously, but I hope that it works.

I'll try to test it soon.
Comment 3 Tomas Smetana 2007-09-03 10:35:06 EDT
Tested both the authentication and TLS and seem to be OK.  I'll try to port it
to Mailman 3 and send the patches upstream.
Comment 4 Tomas Smetana 2007-09-20 07:35:44 EDT
Sorry, but Mailman 3 handles configuration and SMTP in a completely different
way.   I've sent the Mailman 2 patch and we'll see.
Comment 5 George Notaras 2007-11-21 02:28:35 EST
Tomas, thanks. I saw the patch at the mailman patch manager on SourceForge.
Let's hope that Mailman 3 supports 'SMTP authentication' and 'SMTP
authentication over TLS' by default.

Note You need to log in before you can comment on or make changes to this bug.