Bug 253201 - kdeartwork: Can see xscreensaver savers, but I can't use them
Summary: kdeartwork: Can see xscreensaver savers, but I can't use them
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdeartwork   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-17 13:09 UTC by Mary Ellen Foster
Modified: 2008-01-08 19:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 19:31:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mary Ellen Foster 2007-08-17 13:09:26 UTC
Description of problem:
The kdeartwork-kxs package includes the kxsconfig and kxsrun commands, which are
needed for the KDE screensaver module to control xscreensaver screensavers. This
package is required by the kdeartwork-extras package, which is intended to
contain "Artwork Extras, including xscreensaver-based screensavers".

However, it's possible to get into a state where you can *see* the xscreensaver
savers in the KDE screensaver config, but you can't actually do anything with
them. If you install xscreensaver-base and *not* kdeartwork-extras, then the KDE
screen saver config module shows the full list of xscreensaver savers, but none
of them show a preview or can be set-up or used. With the addition of
kdeartwork-kxs, these menu items can be used even without kdeartwork-extras.

This can't be how it was intended to work, can it? What's the point of
kdeartwork-extras if xscreensaver savers can work without it?

Version-Release number of selected component (if applicable):
kdeartwork-3.5.7-2.fc7

How reproducible:
Every time

Steps to Reproduce:
(0. Install xscreensaver-base, uninstall kdeartwork-kxs)
1. Open screensaver configuration
2. Select an xscreensaver saver (e.g., "Apple ][")
3. Click "Setup..." or "Test", or try to use it
  
Actual results:
Nothing happens

Expected results:
The selected screensaver should work, or it shouldn't be shown.

Additional info:

Comment 1 Rex Dieter 2007-08-17 13:20:39 UTC
Confusing alright.  Can't fathom how/why Kcontrol lists items for which there no
longer exist any .desktop file (that's all in kdeartwork-extras).

I'll keep looking.

Comment 2 Douglas Wooster 2007-12-06 05:50:07 UTC
> However, it's possible to get into a state where you can *see* the
> xscreensaver savers in the KDE screensaver config, but you can't
> actually do anything with them.  ...   the KDE screen saver config
> module shows the full list of xscreensaver savers, but none of them
> show a preview or can be set-up or used.

I have this exact symptom on Fedora 8.
I'm unable to identify any "kdeartwork-kxs" or "kdeartwork-extras" RPMs  --  
just kdeartwork.

I do see .desktop files, 
e.g. /usr/share/applnk/System/ScreenSavers/apple2.desktop
Also found
1040588    4 drwxr-xr-x   2 root     root         4096 Dec  4 
23:02 /usr/share/apps/kscreensaver
but it only contains:
-rw-r--r-- 1 root root 53876 2005-09-10 04:14:48 image.png
-rw-r--r-- 1 root root 10664 2005-09-10 04:14:48 kscience.png
-rw-r--r-- 1 root root  1957 2005-09-10 04:14:48 particle.png



I'm unable to identify a kxsconfig or kxsrun command, and I'm unable to locate 
any log containing results of trying to run one of these screensavers (but I 
don't know what to look for, either).

At the moment the only things which work are blank screen and KTux (from 
kdetoys).

I have the following RPMs installed, from the fedora and updates repositories:
kdeartwork-3.5.8-1.fc8
kdetoys-3.5.8-1.fc8
xscreensaver-5.04-1.fc8
gnome-screensaver-2.20.0-10.fc8
xscreensaver-extras-5.04-1.fc8
xscreensaver-base-5.04-1.fc8
xscreensaver-extras-gss-5.04-1.fc8
fedora-screensaver-theme-1.0.0-1.fc8
xscreensaver-gl-extras-5.04-1.fc8
xscreensaver-gl-extras-gss-5.04-1.fc8
fedorainfinity-screensaver-theme-1.0.0-1.fc8
xscreensaver-gl-base-5.04-1.fc8

As far as I know, the new 3D desktop effects are off.  That is, I don't see any 
such effects, but I don't know where to look, to prove that they're configured 
to be off (as opposed to being turned on, but not working).  I do not want to 
use them.




Comment 3 Rex Dieter 2007-12-06 18:41:57 UTC
OK, I think I found what's going on here.

Comment 4 Rex Dieter 2007-12-06 18:45:14 UTC
Stuff in
/usr/share/applnk/System/ScreenSavers/*.desktop
is duplicated in both kdeartwork and kdeartwork-extras.

What needs to happen is that the xscreensaver-based ones need to be in -extras,
what's left, in the main pkg.

Comment 5 Douglas Wooster 2007-12-07 05:46:25 UTC
OK, thanks.  I finally found kdeartwork-extras and installed it.  That pulled 
in kdeartwork-kxs.  xscreensaver-based screen savers now work.  yum says 
the .desktop files are owned by both kdeartwork and kdeartwork-extras.

Comment 6 Rex Dieter 2008-01-08 19:31:02 UTC
%changelog
* Thu Dec 06 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.5.8-2
- include xscreensaver bits only in -extras (#253201)



Note You need to log in before you can comment on or make changes to this bug.