Bug 25322 - Serious vehaviour change in empy php variables
Serious vehaviour change in empy php variables
Status: CLOSED DUPLICATE of bug 24933
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-30 14:07 EST by Victoriano Giralt
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-30 14:07:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Victoriano Giralt 2001-01-30 14:07:31 EST
A critical application of one of my customers has stoped working after
installing php-4.0.4pl1
errara RPM. Suddenly, all empty variables get whitespace that look like
newlines (well the produce newlines in the html generated code), so all
checks for empty strungs fail as newline is not empty. There is a
workaround (trimming everiyhing before use) but that is inducing quite a
big code rewrite.
Comment 1 Nalin Dahyabhai 2001-01-30 15:55:56 EST
Please check if the test packages (php-4.0.4pl1-5) in
http://people.redhat.com/nalin/test/ fix this.  This appears to have been a very
unfortunate side-effect of parsing fixes.

*** This bug has been marked as a duplicate of 24933 ***
Comment 2 Victoriano Giralt 2001-01-30 16:16:45 EST
You've been very fast. I had found the link to your patch in #24933 and tried
the RPMs. The newline, which was realliy prepended to all flieds, has
dissapiared, and everything seems to be back to normal. I have to do some more
tests with the file fields.

Thanks for such prompt response

Note You need to log in before you can comment on or make changes to this bug.