Bug 253223 - When deleting a node from conga, the fence device isn't deleted
When deleting a node from conga, the fence device isn't deleted
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Ryan McCabe
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-17 09:52 EDT by Mark Nielsen
Modified: 2009-04-16 18:59 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0407
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:46:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Nielsen 2007-08-17 09:52:55 EDT
Description of problem:
When a node is deleted from the cluster in conga (i.e. node1), the corresponding
fence device (i.e. node1_fence) is not deleted. This creates a problem when you
attempt to re-add the node to the cluster. You can't add the fence device back
(node1_fence, it doesn't show up on the fence device list though it still
exists). If you try to re-create the fence device, you get an error saying the
fence name must be unique because node1_fence still exists. This forces you to
either manually edit the cluster.conf file and then using ccs_tool to update the
cluster or having to use a different fence device name (I love consistency).

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. set a node up with all fence devices
2. delete the node from the cluster
3. re-add the node and try to re-create the fence device.
  
Actual results:
the fence device can't be added back through conga and a new one with the same
name can't be created.

Expected results:

the fence devices should show up in conga, whether or not they're associated
with a node. This would allow for the deletion of "node1_fence"
Additional info:
This is really more of an annoyance. I can work around this by deleting the
fence device first, then deleting the node. It would be nice if a feature was
added to be able to delete existing fence devices not associated with a node, or
delete unique (not shared) fence devices when the node is deleted.
Comment 1 Jay Turner 2007-11-30 01:24:39 EST
QE ack for RHEL5.2.  Reproducer in the original report above.
Comment 3 Brian Brock 2008-05-14 21:02:50 EDT
I seem to re-add fencing nodes without any problem (no complaints about
duplication of systems), bugfix verified in -7.el5
Comment 5 errata-xmlrpc 2008-05-21 11:46:52 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0407.html

Note You need to log in before you can comment on or make changes to this bug.