Bug 253239 - (CVE-2007-4132) CVE-2007-4132 RHN Satellite xmlrpc flaw
CVE-2007-4132 RHN Satellite xmlrpc flaw
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
reported=20070807,source=redhat,impac...
: Security
Depends On: 251181
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-17 11:08 EDT by Mark J. Cox
Modified: 2007-09-04 04:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 04:46:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark J. Cox 2007-08-17 11:08:45 EDT
During an internal code audit, a flaw was found in an unused back-end xmlrpc
handler added to RHN Satellite 5.0.0.  A remote attacker who is able to connect
to a RHN Satellite server and has valid authentication credentials could use
this flaw to execute arbitrary code on the server as the 'apache' user.

Users of RHN Satellite 5.0.0 are advised to upgrade to 5.0.1 which removes the
unused, vulnerable, handler.

[Note: This issue doesn't affect Red Hat Network hosted, which is how customers
get their updates, it only affects version 5.0.0 of the RHN Satellite product]
Comment 1 Mark J. Cox 2007-08-21 09:04:53 EDT
CVSS v2 Base score: 6.5 (Medium) (AV:N/AC:L/Au:S/C:P/I:P/A:P)
Comment 3 Mark J. Cox 2007-08-29 11:07:46 EDT
removing embargo
Comment 4 Mark J. Cox 2007-09-04 04:46:15 EDT
errata released 20070829, RHSA-2007:0868

Note You need to log in before you can comment on or make changes to this bug.