Bug 253250 - Autofs negative cache regression
Autofs negative cache regression
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity low
: rc
: ---
Assigned To: Ian Kent
Brock Organ
: Regression, Reopened
Depends On:
Blocks: 422551 430698 461297
  Show dependency treegraph
 
Reported: 2007-08-17 11:42 EDT by Guil Barros
Modified: 2009-04-07 11:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 11:24:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 RHEL Product and Program Management 2007-08-17 11:45:50 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 2 RHEL Product and Program Management 2007-08-17 11:55:23 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Jeffrey Moyer 2007-08-17 15:51:12 EDT

*** This bug has been marked as a duplicate of 212249 ***
Comment 4 Ian Kent 2007-08-27 02:35:06 EDT
This bug is for to re-instate the negative timeout
within the autofs4 kernel module. Bug #212249 is
actually is tracking the addition of this functionality
in the user space daemon.

A separate task.

Ian
Comment 5 Ian Kent 2008-04-15 01:37:08 EDT
The addition of mount failure caching proved to be much more
complex than I had hoped and there was a reported oops that
I wasn't able to track down.

This functionality has been implemented in the user space
daemon for the time being but we would prefer it be handled
in the kernel module as it should use less overhead.

So I need to defer this.
Ian
Comment 6 RHEL Product and Program Management 2008-04-15 01:50:25 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 RHEL Product and Program Management 2008-09-03 09:06:18 EDT
Updating PM score.
Comment 8 Ian Kent 2009-04-07 11:24:03 EDT
As described in comment #5 it isn't viable or sensible to get the
caching of failed mount requests to work within the autofs4 kernel
module (this stopped working due to VFS changes in the 2.6 kernel).

Since considerable effort has been invested in providing this
functionality in the user space autofs application in our 2.6 kernel
based products I'm closing this bug as WONTTFIX.

Ian

Note You need to log in before you can comment on or make changes to this bug.