Bug 253290 - [skb] kernel NULL pointer dereference
Summary: [skb] kernel NULL pointer dereference
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 6
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-17 18:55 UTC by Paweł Findeisen
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 2.6.22.7-57.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 22:31:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tail -200 /var/log/messages; service --status-all (5.94 KB, text/plain)
2007-08-17 18:55 UTC, Paweł Findeisen
no flags Details

Description Paweł Findeisen 2007-08-17 18:55:44 UTC
Description of problem:

Null dereference in kernel when performing firewall test (port scanning from
http://crucialtests.com).
Kernel keeps running.

Version-Release number of selected component (if applicable):
Name        : kernel                       Relocations: (not relocatable)
Version     : 2.6.22.1                          Vendor: Red Hat, Inc.
Release     : 32.fc6                        Build Date: śro 01 sie 2007 20:32:05
CEST
Install Date: czw 16 sie 2007 18:45:47 CEST      Build Host:
ls20-bc1-13.build.redhat.com
Group       : System Environment/Kernel     Source RPM:
kernel-2.6.22.1-32.fc6.src.rpm
Size        : 46898185                         License: GPLv2
Signature   : DSA/SHA1, czw 09 sie 2007 16:07:00 CEST, Key ID b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>


How reproducible:
Don't know. crucialtests.com offers only one test for free.

Steps to Reproduce:
1. take a host with fc6, with public IP, no firewall
  and some services running.
2. register at crucialtests.com
3. order a standard online security check (safe mode)
4. check the syslog output
  
Actual results:
Oops

Expected results:
Clear log, probably.

Additional info:

Comment 1 Paweł Findeisen 2007-08-17 18:55:44 UTC
Created attachment 161759 [details]
tail -200 /var/log/messages; service --status-all

Comment 2 Chuck Ebbert 2007-08-31 18:25:08 UTC
Can you get a dump of the packets that cause this?
It would probably have to be run on a separate machine to capture the full trace.

Comment 3 Chuck Ebbert 2007-09-14 19:10:39 UTC
Fix in	kernel-2.6.22.6-55.fc6

Comment 6 Mark J. Cox 2007-09-18 09:36:52 UTC
The discussion points to this commit as being when this was broken:
        http://www.mail-archive.com/git-commits-head@vger.kernel.org/msg08795.html

Therefore since Sun Mar 25 20:10:56 2007 and didn't affect 2.6.18 base (and we
didn't patch this in)

So this issue does not affect the kernels as part of Red Hat Enterprise Linux
2.1, 3, 4, or 5.



Note You need to log in before you can comment on or make changes to this bug.