Bug 253341 - failure to start cluster service which had been modifed for correction
failure to start cluster service which had been modifed for correction
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.0
All Linux
high Severity high
: ---
: ---
Assigned To: Ryan McCabe
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-17 18:43 EDT by Corey Marthaler
Modified: 2009-04-16 18:24 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2007-0642
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:00:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from luci server (13.89 KB, text/plain)
2007-08-17 18:46 EDT, Corey Marthaler
no flags Details

  None (edit)
Description Corey Marthaler 2007-08-17 18:43:21 EDT
Description of problem:
This may be an issue with rgmanger. 

I defined a nfs cluster service consisting of two gfs filesystems. I created
both gfs resources with invalid devices and then attempted to start those
services. The service failed to start, as expected, with the error about not
being able to match a device to what's in the fs resource defination. 

I then corrected the mistake using conga, updated the cluster, and verified that
the .conf file was correct on all nodes. From here, I was unable to successfully
restart the service. Everytime I tried, it remained in the failed state. I then
attemped to restart rgmanager by hand and that worked. I then reloaded luci and
all was happy. 

So why wasn't conga able to start that service without manual intervention? If I
had used conga's big hammer and restarted the whole entire cluster, it would
have probably worked, but an entire cluster restart shouldn't be necessary.


Version-Release number of selected component (if applicable):
ricci-0.10.0-4.el5
luci-0.10.0-4.el5

How reproducible:
everytime
Comment 1 Corey Marthaler 2007-08-17 18:46:11 EDT
Created attachment 161775 [details]
log from luci server

Here is what luci was trying while i was playing around with this.
Comment 2 Ryan McCabe 2007-08-17 19:44:35 EDT
To clarify, when you say you restarted rgmanager, do you mean you did a 'service
rgmanager restart' or did you start it with rgmanager (i.e., clusvcadm -e svcname)?
Comment 3 Corey Marthaler 2007-08-20 09:46:32 EDT
I restarted it with 'service rgmanager restart'.
Comment 4 Ryan McCabe 2007-08-20 11:13:36 EDT
This is a conga bug. Lon says failed services need to be explicitly disabled
before being started again. Patch to be checked in shortly.
Comment 6 Corey Marthaler 2007-08-22 12:03:28 EDT
fix verified in 0.10.0-5.el5.
Comment 8 errata-xmlrpc 2007-11-07 12:00:45 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0642.html

Note You need to log in before you can comment on or make changes to this bug.