Bug 253354 - Virt-Manager does not allow changing RAM allocation for KVM guest
Summary: Virt-Manager does not allow changing RAM allocation for KVM guest
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt   
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-18 05:04 UTC by Jonathan Steffan
Modified: 2007-12-01 15:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-01 15:34:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Steffan 2007-08-18 05:04:47 UTC
Description of problem:
Try adjusting a kvm guests RAM allocation.

Version-Release number of selected component (if applicable):
libvirt-0.3.1-2.fc7.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Run virt-manager
2. Try adjusting RAM for an existing KVM guest.
  
Actual results:
[jon@damaestro ~]$ virt-manager 
libvir: error : this function is not supported by the hypervisor:
virDomainSetMaxMemory
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/details.py", line 448, in
config_memory_apply
    self.vm.set_max_memory(memory*1024)
  File "/usr/share/virt-manager/virtManager/domain.py", line 626, in set_max_memory
    self.vm.setMaxMemory(memory)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 321, in setMaxMemory
    if ret == -1: raise libvirtError ('virDomainSetMaxMemory() failed', dom=self)
libvirt.libvirtError: virDomainSetMaxMemory() failed this function is not
supported by the hypervisor: virDomainSetMaxMemory

Expected results:
RAM allocation changes or is not offered as being able to change.

Additional info:

Comment 1 Daniel Berrange 2007-12-01 15:34:05 UTC
This is not a bug in libvirt. This is a limitation of KVM virtualization - it
has no support for changing guest RAM allocation on the fly.



Note You need to log in before you can comment on or make changes to this bug.