Bug 253368 - a2ps doesn't seem to honor the --encoding=utf-8 option
a2ps doesn't seem to honor the --encoding=utf-8 option
Status: CLOSED DUPLICATE of bug 71496
Product: Fedora
Classification: Fedora
Component: a2ps (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-08-18 07:58 EDT by Sjoerd Mullender
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 13:11:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sjoerd Mullender 2007-08-18 07:58:35 EDT
Description of problem:
a2ps doesn't seem to honor the --encoding=utf-8 option.  Since all my files are
encoded using UTF-8 (after all, that's the default in all versions of Fedora), I
would like to be able to print a file that contains utf-8-encoded non-ascii
characters (i.e. code point > 128).  But using the -X utf-8 option or not using
that option doesn't make a difference in the output: the "latin small letter a
with diaeresis" I'm trying to print comes out as "latin capital letter A with
tilde" plus "currency sign", which happen to be the ISO-8859-1 characters that
correspond to the UTF-8 encoding.

I have also tried changing the option in the file /etc/a2ps-site.cfg, but that
didn't help either.


Version-Release number of selected component (if applicable):
a2ps-4.13b-65.fc7.i386

How reproducible:
Every time.

Steps to Reproduce:
1. Produce a plain text file containing e.g. a letter "ä", encoded using UTF-8
2. a2ps --encoding=utf-8 file-from-step-1
3. Alternatively: a2ps --encoding=utf-8 -o file.ps file-from-step-1; then view
file.ps using evince or some such program.
  
Actual results:
A piece of paper containing "ä".

Expected results:
A piece of paper containing "ä"

Additional info:
Also, since the default encoding on Fedora 7 is UTF-8, the default for a2ps
should also be UTF-8 and not ISO-8859-1.
Comment 1 Sjoerd Mullender 2007-09-06 16:56:33 EDT
When I look at this report with Firefox, I need to set the page encoding to
ISO-8859-1 explicitly to get the effect I meant.
Comment 2 Tim Waugh 2007-09-25 13:11:26 EDT
a2ps doesn't have any UTF-8 support.

*** This bug has been marked as a duplicate of 71496 ***

Note You need to log in before you can comment on or make changes to this bug.