Bug 253373 - Update manager doesn't work!!!
Update manager doesn't work!!!
Status: CLOSED DUPLICATE of bug 253394
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
urgent Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-18 10:02 EDT by Michael
Modified: 2014-01-21 17:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 16:14:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael 2007-08-18 10:02:22 EDT
Description of problem:
F7 update component failed. (Exception Occurred)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Right-click on the notify icon next to the clock in GNOME
2.Select view updates
3.Enter root password (if not login as root)
4.Click Apply Updates
  
Actual results:
When the update manager was resolving dependencies, it failed and an Exception
Occurred window goes up.

Expected results:
Download and install the updates

Additional info:
The content of the Exception Occurred window:

Component: pirut
Summary: TB253c984a depsolve.py:574:_requiringFromTransaction:IndexError: list
index out of range

Traceback (most recent call last):
  File "/usr/sbin/pup", line 409, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 734, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 493, in checkDeps
    (result, msgs) = self.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 540, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 885, in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processReq(dep,
prcoformat_need)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 334, in _processReq
    requirementTuple, errormsgs)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 469, in
_requiringFromInstalled
    return self._requiringFromTransaction(reqpkg, requirement, errorlist)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 574, in
_requiringFromTransaction
    reqpkg = self.tsInfo.matchNaevr(name=name, ver=version, rel=release)[0]
IndexError: list index out of range

Local variables in innermost frame:
requirement: ('perl(DCOP)', 0, '')
checkdeps: 0
dbpkgs: []
pkg: kdebindings-dcopperl - 3.5.7-1.fc7.1.i386
missingdep: 0
self: <__main__.PackageUpdater object at 0x858d3cc>
tspkgs: []
needname: perl(DCOP)
version: 3.5.7
needflags: 0
needversion: 
errorlist: []
pkgmode: None
a: i386
e: 0
name: kdesdk
n: kdebindings-dcopperl
r: 1.fc7.1
v: 3.5.7
release: 7.fc7
requiringPkg: ('kdesdk', '3.5.7', '7.fc7', None)
tsState: None
provSack: <yum.packageSack.ListPackageSack object at 0x8beeb0c>
Comment 1 Jeremy Katz 2007-08-20 14:02:43 EDT
What version of yum do you have installed?
Comment 2 Greta Watson 2007-08-24 16:10:30 EDT
yum --version
    3.2.2

The only package that doesn't install is the kdebindings package.  All other
updates go ok.  So, a work-around is to un-check the kdebindings package and do
the remaining updates.

rpm -q -a -l | grep kdebindings
   shows that version 3.5.7 is already installed on my system.
Comment 3 Jeremy Katz 2007-08-24 16:14:43 EDT

*** This bug has been marked as a duplicate of 253394 ***

Note You need to log in before you can comment on or make changes to this bug.