Bug 253383 - repoquery: --provides does not work with -f
Summary: repoquery: --provides does not work with -f
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-18 16:44 UTC by Till Maas
Modified: 2008-03-13 13:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 13:48:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Till Maas 2007-08-18 16:44:18 UTC
Description of problem:
When I query for a package with "-f" (query for a package that contains a file)
and what to know its provides, this requires two invocations of repoquery.

Version-Release number of selected component (if applicable):
yum-utils-1.1.6-1.fc7

How reproducible:
always

Steps to Reproduce:
1. repoquery --repoid=development --provides -f  /usr/bin/camlp4o
2. repoquery --repoid=development --provides  ocaml-camlp4-devel
  
Actual results:
The two results differ.

Expected results:
Both queries should show the same results, because the first query only matches
ocaml-camlp4-devel.

Additional info:
It seems that this affects also --requires.

Comment 1 Panu Matilainen 2007-08-20 06:21:32 UTC
This is expected behavior: -f is really just an alias for --whatprovides,
--provides and --whatprovides on the same command line doesn't make much sense,
repoquery is just (too) permissive wrt cli-switch combinations.

Would be nice to do better though, but it'll require fair bit of reworking how
the way commandline is handled... I'll see what I can do about it.

Comment 2 Seth Vidal 2008-03-13 13:48:47 UTC
Panu, unless you'd rather leave it open I'm going to close this deferred.


Note You need to log in before you can comment on or make changes to this bug.