Bug 253395 - Software Manager Crashes On gvim Install
Summary: Software Manager Crashes On gvim Install
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: 6
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-18 21:04 UTC by Andrew Piziali
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 18:48:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pirut crash dump captured using [Save to file]. (1.55 KB, text/plain)
2007-08-18 21:04 UTC, Andrew Piziali
no flags Details

Description Andrew Piziali 2007-08-18 21:04:03 UTC
Description of problem: After selecting "vim-X11 - 2:7.0.201-1.fc6.i386 and
clicking the [Apply] button, the "Package selections" dialog box is displayed,
asking to confirm the installation of vim-X11. When the [Continue] button is
clicked, after three or four minutes the software manager crashes, displaying
the "Exception Occurred" dialog box.


Version-Release number of selected component (if applicable): pirut-1.2.8-1.fc6.
 Help -> About only displays "(c) 2005 Red Hat, Inc."


How reproducible: Every time I attempt to install this package.


Steps to Reproduce:
1. Select Applications -> Add/Remove Software
2. Click [Search] tab.
3. Enter "vim" in search box.
4. Click [Search] button.
5. Click check box to the left of "vim-X11 - 2:7.0.201-1.fc6.i386"
6. Click [Apply] button.
7. Click [Continue] button of "Package selections" dialog box.
  
Actual results: "Exception Occurred" dialog box displayed.


Expected results: Successful vim-X11 package installation.


Additional info:

Comment 1 Andrew Piziali 2007-08-18 21:04:03 UTC
Created attachment 161808 [details]
Pirut crash dump captured using [Save to file].

Comment 2 Jeremy Katz 2007-08-20 18:05:26 UTC
What's the output of 'rpm -q pirut yum'?

Comment 3 Andrew Piziali 2007-08-20 19:08:22 UTC
pirut-1.2.8-1.fc6
yum-3.0.3-1.fc6


Comment 4 Jeremy Katz 2007-08-20 21:47:45 UTC
This is fixed with the pirut and yum currently in FC6 updates

Comment 5 Andrew Piziali 2007-08-21 14:50:41 UTC
There do not appear to be newer version of pirut nor yum in the FC6 updates
because when I run the Software Updater (pup), it reports:

    +-----------------------------------------------------------+
    |                     Package Updater                       |
    +-----------------------------------------------------------+
    |                                                           |
    |  Package Updater                                          |
    |                                                           |
    |                                                           |
    |      There are no updated packages currently              |
    |      available for your system.                           |
    |                                                           |
    |                                                           |
    |  [Quit]                                                   |
    |                                                           |
    +-----------------------------------------------------------+

and if I attempt to update pirut and yum using yum, it reports:

    # yum update pirut yum
    Loading "installonlyn" plugin
    Existing lock /var/run/yum.pid: another copy is running. Aborting.
    [root@elijah andy]# yum update pirut yum
    Loading "installonlyn" plugin
    Setting up Update Process
    Setting up repositories
    Reading repository metadata in from local files
    Could not find update match for pirut
    Could not find update match for yum
    No Packages marked for Update/Obsoletion


Comment 6 Andrew Piziali 2007-08-21 14:53:32 UTC
ps. You may safely ignore the first of the two runs of yum above because pup was
running when I ran it.  Also, I am using the fedora-updates repository:
 
    # ls /etc/yum.repos.d
    fedora-core.repo                fedora-legacy.repo
    fedora-development.repo         fedora-updates.repo
    fedora-extras-development.repo  fedora-updates-testing.repo
    fedora-extras.repo



Comment 7 Jeremy Katz 2007-09-12 18:48:59 UTC
Whoops, thought you were on Fedora 7.  We should be catching the cases where a
mirror isn't up to date there.  Given where FC6 is in its lifetime, updating to
try to fix all of the possible cases there is more likely to break things than
it is to help.


Note You need to log in before you can comment on or make changes to this bug.