Bug 253418 - iwl3945 driver needs new firmware
iwl3945 driver needs new firmware
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-08-19 01:03 EDT by Daryll
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-21 09:45:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daryll 2007-08-19 01:03:21 EDT
Running from updates testing.
The kernels:

Both needs iwlwifi-3945-1.ucode
for the iwl3945 driver to work.

That doesn't seem to be available.
Comment 1 John W. Linville 2007-08-21 09:45:51 EDT

There is a patch in those kernels specifically to address this issue.  My 
iwl3945-equipped box is running and only 
has /lib/firmware/iwlwifi-3945.ucode.

Perhaps you are running a different kernel?
Comment 2 Daryll 2007-08-21 11:02:33 EDT
That's my kernel, but when I tried to run it /var/log/messages said:

Aug 18 19:45:22 ninja kernel: iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network
Connection driver for Linux, 0.1.8kd
Aug 18 19:45:22 ninja kernel: iwl3945: Copyright(c) 2003-2007 Intel Corporation
Aug 18 19:45:22 ninja kernel: ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16
(level, low) -> IRQ 16
Aug 18 19:45:22 ninja kernel: iwl3945: Detected Intel PRO/Wireless 3945ABG
Network Connection
Aug 18 19:45:42 ninja kernel: iwl3945: iwlwifi-3945-1.ucode firmware file req
failed: Reason -2
Aug 18 19:45:42 ninja kernel: iwl3945: Could not read microcode: -2
Aug 18 19:45:42 ninja kernel: ACPI: PCI interrupt for device 0000:02:00.0 disabled
Aug 18 19:45:42 ninja kernel: iwl3945: probe of 0000:02:00.0 failed with error -2

uname -a:
Linux ninja #1 SMP Tue Aug 14 18:15:22 EDT 2007 i686 i686 i386

I noticed that the firmware in iwlwifi-3945-1.ucode from the Intel site is not
only in the -1 file, but is a newer version ( than
iwlwifi-firmware-2.14.4-1 (which is the latest I get from yum).

Comment 3 John W. Linville 2007-08-21 12:58:19 EDT
That message indicates that you don't have any firmware at all.  It will 
accept either the old or new names, but only uses the new name in the failure 

'yum install iwlwifi-firmware' should suffice.  I have verified this on both 
the -52 and -57 kernels.

Do you have /lib/firmware/iwlwifi-3945.ucode?
Comment 4 Daryll 2007-08-21 13:49:06 EDT
That's truely strange. I was running it with the previous kernels. Whatever was
just before 52 in upgrades-testing. I rebooted to 57 and it stopped working with
that error. At that point I also had 52 installed, so I rebooted into that and
had the same problem. I found the message in the log and connected a wired
ethernet, went to the Intel site, grabbed the new firmware, dropped it in place,
and it worked fine.

I do have iwlwifi-firmware-2.14.4-1 installed. Maybe something got corrupted
somewhere. I'll try removing that package and reinstalling it and see what happens.

Comment 5 John W. Linville 2007-08-21 14:02:14 EDT
Just a thought -- did you boot the -52 or -57 kernel _after_ updating the 
iwlwifi-firmware package?  If you updated iwlwifi-firmware after the failure 
and didn't reboot or reload the module then it still would not have worked.

Note You need to log in before you can comment on or make changes to this bug.